Jump to content

UNRAID 6.3.5 - Docker Engine (all dockers) non responsive


Frostyfruit

Recommended Posts

Hi all,

 

I am having some weird issues which looks like its coming from my Docker Engine.

 

The issue started about a week ago and comes across as these symptoms

1. Dockers seem unresponsive i.e. Emby Tvheadend etc..

2. When I go to the Docker menu  - They are all showing as running however when I try to goto their respective Webui they are not responsive

3. I Dont think stopping and Starting makes any difference

:$

 

Below are a set of steps I have tried

1. Delete Docker Img - re-create and add all containers back

2. Docker image is 30GB with 5GB being used

3. stopping and starting docker engine from command line via  /etc/rc.d/rc.docker stop / start seems to restore things

 

I have ran a diagnostic and I see these two errors come up int the Docker log file

 

time="2018-08-02T06:17:24.90385105+10:00" level=info msg="stopping containerd after receiving terminated" 
time="2018-08-03T17:51:27.298044846+10:00" level=info msg="stopping containerd after receiving terminated" 
 

Any advice or thoughts to help troubleshoot would be ace!

 

Link to comment

Ok I have tried to see if there is a specific container causing this issue but cant seem to find it.

 

The weird thing is that CA Advisor shows memory at 96% however when i run 

Docker stats

The memory on each container is hardly being used.

 

Any thoughts anyone? or what else to check for?

 

 

docker.jpg

Link to comment

Since you're not in a specific container, cAdvisor is showing the total memory used on your system, including some caching.  Getting the stats on a particular container will show the memory usage of it, exluding caching.

 

Diagnostics (after doing whatever you do to get the symptoms in the OP) is always a plus when posting

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...