Jump to content

keyboard not working in Ubuntu 18.04.1 VM


Recommended Posts

i got have i little problem, my main keyboard isn't working, its works fine in Unraid it self but it isn't in  the VM.

it is Logitech illuminated 820-001272.

the motherboard has only USB gen 3 inputs....

I can see t keyboard in LSUSB

$ lsusb
Bus 001 Device 005: ID 46f4:0001  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver ----> wireless mouse, works fine
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver  ----> the K400R
Bus 002 Device 002: ID 046d:c318 Logitech, Inc. Illuminated Keyboard  <<<<--- it is visable, but not working
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

the logitech K400R (wireless mouse and keyboard in one) works fine, but that one isn't fine for daily use.


who knows the solution for this?


pc spec:

Threadripper 1950X

Gigabyte X399 aorus gaming 7

32 ram


Schermafdruk van 2018-08-07 19-46-48.png

Link to comment

well, the not working keyboard isn't the only problem, did try instal a Win10 VM. the GPU was stuck in D3 mode, had to reboot Unraid to get it back alive...

and after i boot the win10 VM the keyboard still not workings, i am going to try a USB2 port...


will search for more info about IOMMO and vfio and NTP errors...

Link to comment

Fixed it!!!


replace the illuminated keyboard for a Logitech K270, not a really great keyboard but it does the jop. (it makes much more typing sound)

it has got have the same vendor en device id but that was fixed with some xml edit.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...