Jump to content

PE R720 - Cannot boot off of unRAID flash drive


Recommended Posts

Just bought a Dell PowerEdge R720 and want to use unRAID with it. I've previously used ESXi, but I like the features unRAID has to offer. I plan to use the trial version to test things out so I used the USB media creator. This server refuses to boot into the unRAID OS. I've tried the same flashdrive on a different computer and it boots up fine.


Thing's I've tried:

  • Updating BIOS
  • Setting boot mode to BIOS
  • Setting boot mode to UEFI
  • Applying default settings
  • Changing default boot devices
  • Making sure my flashdrive is FAT32
  • Removing all but one stick of memory
  • Removing all expansion cards
  • Using different USB ports
  • Using a Windows 10 install disk to verify if it's even able to boot to an OS, which it did. 


If I boot using BIOS (Legacy) mode, I can get to the unRAID boot menu. Booting into "unRAID OS" and I get a black screen and nothing else. The fans spin down and the activity light on the flash drive stops blinking.

If I boot using UEFI mode, I can also get to the unRAID boot menu. Upon booting I get "Failed to allocate memory for kernel command line, bailing out. Booting kernel failed: Bad file number". Any other boot option yields the same error.


I've used both the USB creator and the manual install method multiple times and I still can't boot. I have also tried using another flashdrive.


Booting from UEFI mode:


Link to comment

Yes I tried 6.5.2 both normal and efi and I still get the same error. Turns out whatever I used to upgrade the BIOS earlier didn't catch the latest version so when I went back to check for it, there was a new one! I got my hopes up too soon though, because after a successful flash it still wouldn't boot off of the flash drive.


There is one thing that might be causing it but I highly doubt it. It's missing its internal network card which halts the system during POST waiting for an F1 key strike to continue the boot process. I might be wrong but I don't think a network card would be causing memory allocation errors :/ 

Link to comment

FINALLY! It works.


It still shows a black screen when I boot using Legacy mode, but after putting in a network card that I had on hand I saw it grab an address and I am able to access the web ui. 


The console shows up after some time but it seems to be intermittent. It sometimes comes up immediately after boot and sometimes it never comes up. I added an extra graphics card after remembering Linus' video about unRAID needing to have a dedicated video card to grab, but I get the same result. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...