Jump to content

failure building VM's

Recommended Posts

Hey guys,


Long time unraid user here, I have had Virtual machines running on my unraid servers for many years. lately I only 1 VM running and it would crash regularly (VM would shut down with no errors logged in event viewer), Unraid would sometimes show a network card error. 


My hardware profile is attached

 Basically it is a custom built PC/Server with 

AMD fx8350 8 core cpu

32gb ram

Asus mother board (I forget what model but I will go look in a bit)

12 disks total (1 parity, 7 data, 4 parity ranging from 1tb to 8tb)



Starting maybe 6 to 8 months ago I had 2 VMs running 1 Windows server and one windows 7 client, the Server was never powered on except when needed, and was deleted 4 to 6 months ago. The Windows 7 box was running 24/7 BUT starting 6 to 8 months ago the client would crash anywhere from 1 to multiple times a day, typically when there was heavier network traffic. I changed the network card used by the client and things seemed better, then I had a cache disk drop out of the cache array for some reason and i lost the Windows 7 VM, I added the cache disk back in to the array and it has been running perfect for several months with no errors on the cache disk, so I m not sure why the disk dropped out...



In the last couple weeks I have tried to rebuild the win 7 client many times, and every time the install of windows error out with a "Windows cannot install required files. The file may be corrupt or missing. Make sure all files required for installation are available, and restart the installation. Error code: 0x80070570". I have also tried installing Windows 8, 8.1, Win7 with sp1, Win7 without sp1, and Windows 10 Every install fails with some error having to do with not able to communicate with the network, or not able to load files. This happens on every install during Expanding Windows files. 


I have tried creating the Virtual disk on the cache and on a disk with nothing else on it, both cases end in the same errors


I have tried various amounts of RAM, various CPU cores ranging from 2 to 4 cores. 


I have tried different bios settings, different machine types etc and I am now at a loss. 


The other issue I have seen is when trying to delete .img files while troubleshooting this is that I get an error stating the trash is full and unraid is unable to delete the file, I ended up having to use a file manager (Dolphin) and using Shift Del to delete the img files without hitting the trash. 


I'm guessing this might have something to do with the cache disk dropping out of the array a few months back, but I have no clue. 


I do see a few things in the Cache array that seem out of the normal, some things that seem like they should have been moved to a different folder, some are in the correct folder as well as the cache folder, so maybe there is an issue with the cache drives/array? 


Should I maybe take the cache drives offline and run a wipe on all of them to "clean up" the array? 


Link to comment
  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...