Jump to content
gacpac

Solved | Wanted to install Sophos home Firewall in Unraid

18 posts in this topic Last Reply

Recommended Posts

I tried setting up Sophos to try it out, but then the stupid KVM doesn't detect the virtual network cards. Can somebody help me a little bit with this?

Edited by gacpac
Topic solved

Share this post


Link to post

are the cards set as virtio or did you specify e1000? I know for OSX you need to change the type for it to work.

 

 <interface type='bridge'>
      <mac address='xx:xx:xx:xx:xx:xx'/>
      <source bridge='br0'/>
      <model type='e1000-82545em'/>
      <address type='pci' domain='0x0000' bus='0x09' slot='0x01' function='0x0'/>
    </interface>

Share this post


Link to post

I set the VM settings to be OVMF and it picked it up. But I had another problem that for some reason after it installs the default password doesn't work. And that truly doesn't make sense. 

 

If somebody have some quick instructions or something special please let me know

Share this post


Link to post

Are you using https://IP.add.re.ss:4444 to connect and do the initial configuration? The page at https://IP.add.re.ss is just for user login and it will fail initially, because there are no users defined. Default is https://172.16.16.16:4444/

Edited by thomas
added default IP address

Share this post


Link to post

I'm trying to login using the https://x.x.x.x which is what I've read. The problem I have is that no matter what I do, I can't go to the default https://172.16.16.16:4444/ and no matter what I do. 

Share this post


Link to post

Maybe a silly question, but you have changed your IP to be able to access the 172.16.16.16?

 

You can try ping it first, to know that is accessible...

Share this post


Link to post

Try also deleting the browser cache or using an incognito tab...

Check also you're using the Lan side, because the Wan side doesn't allow access to :4444 port...

Edited by thomas

Share this post


Link to post
30 minutes ago, thomas said:

Try also deleting the browser cache or using an incognito tab...

Check also you're using the Lan side, because the Wan side doesn't allow access to :4444 port...

I'm trying to set it up with Virtual interfaces, which technically are both Lan interfaces. I know I've done it before in VMware

Share this post


Link to post

They are both on LAN, but the WAN side will get an IP from the DHCP server that you have, while the other one will be 172.16.16.16. So you have to change your IP to be in the same subnet to be able to connect. 

Also you can connect with VNC and change the LAN side IP from the VM terminal. Default password is admin...

Share this post


Link to post

I made a test install for Sophos XG Firewall, but for me it only booted with Seabios, not OVMF. After install, I changed my computer's IP to 172.16.16.5 255.255.255.0 and I could access the https://172.16.16.16:4444 and do all the configuration...

Share this post


Link to post
1 minute ago, gacpac said:

If you use Seabios. What drivers you use for the disks? That's where I have issues 

I don't recall if I had to switch the disks from Virtio to SATA, but you can try it. I can check later today to see...

Share this post


Link to post

Omg, I set up as SeaBios using Machine i440fx-3.0 and the system was detected as a KVM Virtual Machine. Then everything in SATA port.  I've also spin up a Windows 10 VM.

 

Setup my IP as you said and bro it worked perfect. Now I can play with it, set it up as a bridge or maybe firewall in the future. 

Share this post


Link to post

Another question if possible. How did you setup your network cards for the VM. Because I set them on bridge and my whole network went down.  

Share this post


Link to post
8 hours ago, gacpac said:

Another question if possible. How did you setup your network cards for the VM. Because I set them on bridge and my whole network went down.  

I left them default, the only change I made is the type to "e1000-82545em" and everything works properly.

 

Add Solved to the topic name, if there are no more issues...

 

Share this post


Link to post

I left everything default to. Well, I wanted the bridge functionality, but I had to change one of the network cards to vbr0 in the settings. 

 

Today I'll work on it but at least I got it to install. Even though I have to go to the https://ipaddress:4444 

 

I guess the other side is for user access only. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now