Jump to content
Sign in to follow this  
dvd.collector

Raid 0 cache?

12 posts in this topic Last Reply

Recommended Posts

I want to use two ssd's in a raid 0 configuration as a cache drive.

 

I created a RAID0 array in the bios of my unraid server, however unraid does not seem to see that - it still sees the individual disks.   Is this expected?

Share this post


Link to post
5 minutes ago, dvd.collector said:

it still sees the individual disks.   Is this expected?

Yes, Unraid doesn't support most RAID controllers, and definitely not "fake" RAID like Intel RST or similar, you can use a btrfs pool and change the profile to raid0:

 

https://forums.unraid.net/topic/46802-faq-for-unraid-v6/?do=findComment&comment=480421

 

Share this post


Link to post

Thanks for the quick reply.

 

I don't suppose I have much choice, but is a btrfs raid 0 pool as fast as I would expect (e.g nearly double the speed of a single ssd)?

 

Lee.

Share this post


Link to post

OK, I removed the raid 0 from the bios and added both ssd's as cache drives.  Now I see the attached error message.

 

Clicking format does nothing.

 

error.jpg

Share this post


Link to post

OK, so I stopped the array, ran the blkdiscard command on both disks, restarted array but see the same error message.

 

Should I have removed them as cache drives first?  I'll try that now anyway.

Share this post


Link to post

Attached Diagnostics.

tower-diagnostics-20181108-1929.zip

 

Can see this in the logs, is it trying to format one drive as XFS?

 

Nov 8 19:26:34 Tower emhttpd: shcmd (1000): /sbin/wipefs -a /dev/sde1

Nov 8 19:26:34 Tower emhttpd: shcmd (1001): mkfs.xfs -m crc=1,finobt=1 -f /dev/sde1

Edited by dvd.collector

Share this post


Link to post
4 minutes ago, dvd.collector said:

is it trying to format one drive as XFS?

Yep, don't know why, never seen this before but it looks like a bug.

 

With the array stopped click on cache and change filesytem to btrfs.

Share this post


Link to post

OK so when I click on Cache, I can change that to btrfs.   When I click on cache2, it says "unknown" in partition format.

 

Went ahead and changed Cache to btrfs anyway then clicked format.

 

It looks like this worked (see screenshot).

 

Now just need to change to raid 0 i guess.

error2.jpg

Edited by dvd.collector

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this