Jump to content
Sign in to follow this  
khile

issues passing though nic

3 posts in this topic Last Reply

Recommended Posts

Hi  all being trying to get pfsense running using an pci nic card (hp branded intel card)

 

ive followed a few guides to stop unraid using it on boot  i can  select them in the vm but when i try and boot i get this error

 

internal error: qemu unexpectedly closed the monitor: 2018-11-27T23:57:22.977816Z qemu-system-x86_64: -device vfio-pci,host=04:00.0,id=hostdev0,bus=pci.1,addr=0x0: vfio error: 0000:04:00.0: failed to setup container for group 16: failed to set iommu for container: Operation not permitted

 

IOMMU group 16:	[8086:105e] 04:00.0 Ethernet controller: Intel Corporation 82571EB/82571GB Gigabit Ethernet Controller D0/D1 (copper applications) (rev 06)
IOMMU group 17:	[8086:105e] 04:00.1 Ethernet controller: Intel Corporation 82571EB/82571GB Gigabit Ethernet Controller D0/D1 (copper applications) (rev 06)

Thank You

Edited by khile

Share this post


Link to post

looking in logs i see

 

 Tower kernel: vfio_iommu_type1_attach_group: No interrupt remapping support. Use the module param "allow_unsafe_interrupts" to enable VFIO IOMMU support on this platform

 

ive edited my  linux file

 

default menu.c32
menu title Lime Technology, Inc.
prompt 0
timeout 50
label Unraid OS
  menu default
  kernel /bzimage
  append vfio_iommu_type1.allow_unsafe_interrupts=1 pcie_acs_override=downstream vfio-pci.ids=8086:105e initrd=/bzroot
label Unraid OS GUI Mode
  kernel /bzimage
  append initrd=/bzroot,/bzroot-gui
label Unraid OS Safe Mode (no plugins, no GUI)
  kernel /bzimage
  append initrd=/bzroot unraidsafemode
label Unraid OS GUI Safe Mode (no plugins)
  kernel /bzimage
  append initrd=/bzroot,/bzroot-gui unraidsafemode
label Memtest86+
  kernel /memtest

ps the server is a dell r710 with hp branded dual port intel nic 

tower-diagnostics-20181129-0433.zip

Edited by khile
attach Diagnostics file

Share this post


Link to post

Anybody im out of ideas nothing seems to be working 

 

tried a different card got same  error 

 

internal error: qemu unexpectedly closed the monitor: 2018-11-30T17:47:47.246753Z qemu-system-x86_64: -device vfio-pci,host=09:00.0,id=hostdev0,bus=pci.3,addr=0x0: vfio error: 0000:09:00.0: failed to setup container for group 19: failed to set iommu for container: Operation not permitted

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this