Cannot connect to Web GUI

Recommended Posts

[Solved] It turns out my very old unraid install was setup with DCHP set to "off" and I assume the hardcoded IP's weren't playing nice with a different router system. We're back up and running.  Unsolved. Back at trying to fix... 


Hey folks - longtime unraid user with very little troubleshooting knowledge. My box has been running smooth for years now until my wife dropped the machine (long story) and it wouldn't boot up anymore (sad). I made a new build to put the drives in and everything set up pretty smoothly, but can't get connected to Web GUI. I've set everything up and based on what I've read, just put the thumb drive into the machine. It's an older version of unraid - a few years at least, I think I last upgraded in 2014 (I know, I know - but if it ain't broke, don't fix it). 


Long story short, after some initial BIOS troubleshooting I've been able to get unraid running but Web GUI won't load from any of my browsers - the connection just times out. Things I've tried so far, based on posts I've been able to find ("network not working" troubleshooting guide provides little to help):

* inet IP address shows up with ifconfig eth0 command; so I assume it isn't explicitly network access related (i.e. box is connected to internet)

* tried //tower, //IP_address, http://tower, http://IP_address, the https versions of those in browser

* tried the above in both safari and IE, and on mac (tower.local) and PC

* this exact thumb drive worked previously in the old box so I know it's FAT32 formatted etc

* OS thumb drive tried in all USB slots, same with ethernet cable

* verified disks are being read / loaded with dmesg|grep SATA|grep link

* tried removing the http→https forwarding using instructions i found here; didn't seem like the best way to do this, but not sure how else to try

* ran df command and have a photo of it if helpful but ran out of time to write & capture the syslog file for that attempt at this

* have NOT yet run memtest but I'm not sure that helps this kind of issue? reason I haven't tried that yet is because the computer starts screeching (I'm pretty sure it's high CPU/mobo temp alarm based on "sensors" readout) - so I'm reluctant to let the computer just run memtest all day in case I cook my gear. I was hoping to get things up and running and get access to my old data before troubleshooting what's causing the screeching.


As I mentioned, it's an old version of unraid but I'm afraid of upgrading given how much data is still on the hard drives. If that might be my problem, I can try that next but didn't want to risk losing data - I've found very little on whether or not this is a risky move (upgarding hardware and OS at the same time).


Syslog is attached and am happy to try to produce whatever else I can to troubleshoot. Thanks so much in advance for any help folks can provide!


Edited by seamusmcaffrey
Link to comment
13 hours ago, trurl said:

Are you sure you had the go file running emhttp using the default port 80?


Looks like you have unMenu, have you tried to access it on the unMenu port (8080)?

I'm not sure what the "go file" or "emhttp" are but I'll google those things and have a look when I get home tonight! 


I tried accessing it at 80 and 90 based on some posts I saw that suggested those were default, I'll try 8080. my understanding of the way to do this is http://ip_address:8080 but let me know if that sounds wrong.


Thanks for the ideas!

Link to comment

You are using a very, very old version of Unraid and you will have to work with us to figure out what you have since you can't easily get us the information we need and expect when troubleshooting the newer versions. And none of us have used the version you have for many years.


The default web port is 80, and that is what your browser uses when you don't specify a port.


8080 was the port used by Unmenu, which was an addon for that old Unraid that provided some additional functionality.


Your go file should be on your flash drive in the config folder. It has the command in it to start the web interface. Find that file and post it here.


Link to comment
8 hours ago, trurl said:

You are using a very, very old version of Unraid


I sure am! As mentioned, it worked fine and saw no reason to upgrade while it worked for my purposes. 


Anyways - great news - making me aware that this file exists enabled me to go in and poke in other config settings; I found that my config file was set to turn off DHCP, I'm sure I had a reason in the past to do it this way...  turning this back on opened me up to perfectly usable IP address for access and we are back in! Turns out I'm on 5.0-rc12a. So I guess it's time to upgrade so I don't have this problem in the future :)


Unless someone knows of a better resource, I'll follow the guide to get myself up to date now! Though I'd appreciate any warnings of potential data loss if that feels like a thing that could happen... but I can do more research from here.


Thanks so much for ya'lls help!

Link to comment

Sadly - I'm back. Last night I was able to log on immediately after turning "use DHCP" back on, so I shut down and figured I could deal with the rest of setup the next day. 


Unfortunately, I booted up the machine today to clean everything up and the Web GUI didn't work at all. It worked fine yesterday after reloading at http://tower ... I tried using several different ports (:8080,80,90, etc) and it still isn't connecting. So, not sure what's up. I've attached my go file and am happy to provide/try anything else if folks have ideas!


Link to comment

That go file seems to launch unMenu 3 times. Not sure what unMenu would do if you launched it when it was already running. In any case, removing those last to 2 lines can't hurt.


You might also try connecting using the IP address instead of the name "tower".


Did you check the network.cfg file again to make sure it was still using DHCP?


Do you have an attached monitor and keyboard? From the command line you can check the IP address it is getting with



Link to comment

And, just for the heck of it, try booting in safe mode from the boot menu and see if that makes a difference


Also, rename the "packages" and "extra" folder on the flash drive to something else and try rebooting to see if that makes a difference



Edited by Squid
Link to comment

Got it - lots of things to try! I likely won't be able to for a few days at minimum but this is lots to work with, thank you.


I have tried accessing via IP address and //tower - neither work. I hadn't checked the network file again but I guess it's possible it got overwritten somehow; will double check! I've checked ifconfig eth0 and it was still returning an IP address - the same one as it did last night when it worked.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.