Jump to content
steve1977

Cannot start VM Win10

8 posts in this topic Last Reply

Recommended Posts

I have a WIn10 VM that I am using for a long time. Never had any issue.

 

It is now broken and no idea what caused this:

 

When starting the VM, I see a screen "Guest has not initialized the display (yet)". This stays forever and I can never have access to Windows. VM log below:

 

https://pastebin.com/efbaRyC9

 

I found a forum post suggesting to recreate a VM with the same vdisk. I used identical settings and it indeed gives me a different error. However, it also doesn't boot up. Instead of "guest has not...", it gives me a forever Tianocore screen. So, different from above, but not better. Log below:

 

https://pastebin.com/PdXmNSLs

Share this post


Link to post

The newly created VM, set it up with only one core and check if it boots up now. You can change back the core assignment later. Sometimes on a fresh install of Windows, people encounter that issue. Did your VM upgraded from 1803 to the latest Windows 1903 maybe???

 

Another cause could be your vdisk is faulty. Do you make regular backups of that file and can revover from a backup?

Share this post


Link to post

Thanks!

 

Just tried with one core. Don't know about windows upgrade.

 

Unfortunately no backup.

 

Any other idea?

Share this post


Link to post

Inb4 you screw up something, make a copy of the vdisk. Did you updated something on Unraid lately or did you changed anything hardware related? If nothing changed, no new devices, no updates to unraid the chances are high the vdisk has some errors on it or your hdd hosting the disk has some issues.

 

How full is your disk where the vdisk is sitting on?

 

If you have another windows VM, you can temporarly mount the vdisk as second drive and can check if you can access the filesystem or you can run a chkdsk on the filesystem to repair files if there are some.

chkdsk Z: /f /r /x

replace Z with the drive letter

 

Share this post


Link to post

Thanks. I tried to mount it with another VM. It says the file is corrupted. Game over or anything I can still try?

Share this post


Link to post

You can mount it to a Linux VM and try to recover important files if you need to. Recover a corrupted vdisk file itself, I don't know if there is a way. If you aren't able to mount the vdisk to a VM and can't access the filesystem, the chances are really low to get any data back.

 

For the future, here is a easy way to backup your VMs via script. Have a look into it. I'am using Jtoks script over a year now and it just works. If you need to recover a VM just replace the vdisk with the file from the backup. With the plugin userscripts you can run the script automated every day, week or how you like. Add the path where to store the backup, the name of the VM you wanna backup and some options for example how many backups to keep, reset state of the VM after the backup, compression etc.

 

https://github.com/JTok/unraid-vmbackup

 

 

Share this post


Link to post

Thanks. I have made some progress and reach the "startup repair" of Windows and can also select the command line. I've ran a chkdsk /r.

 

Unfortunately, I am still stuck and cannot get it to start. But it seems I am closer now.

 

Any thoughts?

Share this post


Link to post

Some more progress, but still not getting there.

 

I have mounted the vdisk as a secondary vdisk to another VM. This seemed to work flawless. However, the disk showed offline with the error message that it has the same "signature" as another online disk. I ignored this comment and just clicked it online. I can see the file system and can browse some folders. However, I cannot access the user folder as it says that I don't have the user permission.

 

Any additional thoughts appreciated! Thanks.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.