Jump to content

Adding a NVIDIA GPU as my Primary GPU for VM

6 posts in this topic Last Reply

Recommended Posts

I am trying to add a Nvidia GPU to my VM as the Primary GPU, 

I have create the Vm, using the default VNC and no Sound, but now I am trying to add the sound and GPU.


I have checked my IOMMU, and discovered that I need to set change the PCIE witin the VM so I did the following


in the Vm Manager I change the PCIe ACS Overide to Both



resulting with this within my  IOMMU



then I added the GPU Nividia Geforce GTX card, to my VM and booted, but when I go to start the console I see that this option is gone, and when I try to search the the Vm on the domain I discovered that it is not showen.




I get no errors message, when the VM boots up, 

what I am I missing

Share this post

Link to post

If you only use a dedicated GPU there is no option for a "console". You have to plug in a display to the GPU to see the output.

Share this post

Link to post

In most cases you need a physical device pluged into the GPU. There are dummy HDMI sticks available to emulate a connected display. In some circumstances without a device connected the GPU wont initialize correctly and you can't use it in the VM. If the card works inside the VM you have different options to connect to the VM remotely such like RDP, VNC or Teamviewer. But for gaming for example, don't expect smooth frame rates like on a usual monitor if you connect remotely.

Share this post

Link to post
Posted (edited)

Cant you click the plus to add an additional GPU and enable VNC as a secondary GPU on the VM?

Edited by helin0x

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.