Stuttering FPS in W10 VM


Recommended Posts

I have been having issues with stuttering FPS on a Windows 10 VM I have been trying to setup. 

New build with the following specs:


Ryzen 3900x

MSI Carbon Pro x470

32GB DDR4 2400 (Yes, it should be 3200+)

Sapphire 5700xt reference

Sabrent Rocket 512 NVME drive


The VM is given 6/12 cores/threads and the GPU and NVME drive is passed through to the machine.


I was able to follow Spaceinvadors guide for installing a W10 VM using a passed through NVME drive so that I am able to boot to the Windows install bare metal or as an unraid VM.


I expect a performance loss when booting as a VM because of the extra overhead from Unraid as well as the fact that the PC won't have as many CPU cores to work with, but the stuttering is worse than just running at a lower FPS.


Booting up bare metal, if I run the Shadow of the Tomb Raider benchmark @1080p, highest settings with motion blur off I get ~120FPS average.  Everything looks nice and smooth.  Running it in the VM I get ~102 FPS average.  I was somewhat expecting a drop like that, but the problem is the "1% lows" or whatever its called.  You can see the FPS dip every 2-3 seconds and it creates a visible stutter.  The charts show the milliseconds between frames spike at those times.


I have been going through the suggestions around here and elsewhere and these are the things I have tried:


So far I've done the following:

  • Used the tips and tricks plugin to set the CPU governor to Performance and made sure performance boost is enabled.
  • Isolated the cores pinned to the VM using the isolcpus command. 
  • Pinned the emulator to core 0,12 with the emulatorpin command.  
  • Set the power settings in windows to performance.
  • Updated the BIOS and all drivers to the latest and greatest.


Lowering the settings in the game don't help.  The FPS doesn't go up and the stuttering still exists.  I'm somewhat at a loss as to what else I should try.

Link to comment

post your xml please :)


do you have the fps drops as soon as you move your mouse?

if so, go to your mouse tool and change the frequency to 125Hz and check if it's better.


I had that issue when running without "hypervisor" cpu flag.


so better provide some more information about your system (VM xml, system devices, drivers etc)



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.