6.8.3 Remote VNC stuck on black screen during Linux installation


3 posts in this topic Last Reply

Recommended Posts

Hi All,

 

As the titel say, I'm running into the below issue. 

Everything worked fine and dandy for a couple of days, so I decided to buy a license, and added more disk to my cache. Then the problems started. At first, the VM's started getting extremely slow during installation. It took a long time to move from on step tp another during installation, and pressing buttons during installation had input lag upwards of 1 minut. Even if the domains share was set to only run on cache. Then they went on to my current situation.

When I first boot the VM up. and connect I get the ubuntu boot menu. Choose my option and get to the disk checks. When that completes all I get is a black window. No writes are beeing done to the disk, but the dedicated cores keeps being utilized anywhere from 50-100% (Depends on how many cores I assigned).

 

Here's what I've so far:

Using different browsers : no luck

Using UltraVNC instead of Remote VNC: Same result - just a black screen.

Tried both Ubuntu Desktop, Server end CentOS 8: Same result - just a black sceen.

Reformatted all array and cache drives. And re-created the Unraid USB: Didn't change a thing.

 

I assume the VM's are working as intended, and waiting for my input to continue the installation - I just can't remote control them.

 

I've been battling the issue for quite a few days, not beeing able to find similar issues online. I guess my google-fu is that bad... I'm hoping I overlooked something extremely simple.

 

The VM logs:

-boot strict=on \
-device pcie-root-port,port=0x10,chassis=1,id=pci.1,bus=pcie.0,multifunction=on,addr=0x2 \
-device pcie-root-port,port=0x11,chassis=2,id=pci.2,bus=pcie.0,addr=0x2.0x1 \
-device pcie-root-port,port=0x12,chassis=3,id=pci.3,bus=pcie.0,addr=0x2.0x2 \
-device pcie-root-port,port=0x13,chassis=4,id=pci.4,bus=pcie.0,addr=0x2.0x3 \
-device pcie-root-port,port=0x14,chassis=5,id=pci.5,bus=pcie.0,addr=0x2.0x4 \
-device ich9-usb-ehci1,id=usb,bus=pcie.0,addr=0x7.0x7 \
-device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pcie.0,multifunction=on,addr=0x7 \
-device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pcie.0,addr=0x7.0x1 \
-device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pcie.0,addr=0x7.0x2 \
-device virtio-serial-pci,id=virtio-serial0,bus=pci.2,addr=0x0 \
-blockdev '{"driver":"file","filename":"/mnt/user/domains/Ubuntu/vdisk1.img","node-name":"libvirt-2-storage","cache":{"direct":false,"no-flush":false},"auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-2-format","read-only":false,"cache":{"direct":false,"no-flush":false},"driver":"raw","file":"libvirt-2-storage"}' \
-device virtio-blk-pci,scsi=off,bus=pci.3,addr=0x0,drive=libvirt-2-format,id=virtio-disk2,bootindex=1,write-cache=on \
-blockdev '{"driver":"file","filename":"/mnt/user/isos/ubuntu-20.04-desktop-amd64.iso","node-name":"libvirt-1-storage","auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-1-format","read-only":true,"driver":"raw","file":"libvirt-1-storage"}' \
-device ide-cd,bus=ide.0,drive=libvirt-1-format,id=sata0-0-0,bootindex=2 \
-netdev tap,fd=35,id=hostnet0,vhost=on,vhostfd=36 \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:c3:3f:c3,bus=pci.1,addr=0x0 \
-chardev pty,id=charserial0 \
-device isa-serial,chardev=charserial0,id=serial0 \
-chardev socket,id=charchannel0,fd=37,server,nowait \
-device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.qemu.guest_agent.0 \
-device usb-tablet,id=input0,bus=usb.0,port=1 \
-vnc 0.0.0.0:0,websocket=5700 \
-k da \
-device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,max_outputs=1,bus=pcie.0,addr=0x1 \
-device virtio-balloon-pci,id=balloon0,bus=pci.4,addr=0x0 \
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
2020-05-11 12:25:33.819+0000: Domain id=2 is tainted: high-privileges
2020-05-11 12:25:33.819+0000: Domain id=2 is tainted: host-cpu
char device redirected to /dev/pts/0 (label charserial0)

 

The main log:

 

May 11 04:47:54 Tower dnsmasq[2921]: started, version 2.80 cachesize 150
May 11 04:47:54 Tower dnsmasq[2921]: compile time options: IPv6 GNU-getopt no-DBus i18n IDN2 DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth no-DNSSEC loop-detect inotify dumpfile
May 11 04:47:54 Tower dnsmasq-dhcp[2921]: DHCP, IP range [IP-Range], lease time 1h
May 11 04:47:54 Tower dnsmasq-dhcp[2921]: DHCP, sockets bound exclusively to interface virbr0
May 11 04:47:54 Tower dnsmasq[2921]: reading /etc/resolv.conf
May 11 04:47:54 Tower dnsmasq[2921]: using nameserver [DNS IP]#53
May 11 04:47:54 Tower dnsmasq[2921]: using nameserver [Gateway IP]#53
May 11 04:47:54 Tower dnsmasq[2921]: read /etc/hosts - 2 addresses
May 11 04:47:54 Tower dnsmasq[2921]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses
May 11 04:47:54 Tower dnsmasq-dhcp[2921]: read /var/lib/libvirt/dnsmasq/default.hostsfile
May 11 04:47:54 Tower kernel: virbr0: port 1(virbr0-nic) entered disabled state
May 11 04:47:54 Tower kernel: L1TF CPU bug present and SMT on, data leak possible. See CVE-2018-3646 and https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/l1tf.html for details.
May 11 04:48:03 Tower kernel: br0: port 2(vnet0) entered blocking state
May 11 04:48:03 Tower kernel: br0: port 2(vnet0) entered disabled state
May 11 04:48:03 Tower kernel: device vnet0 entered promiscuous mode
May 11 04:48:03 Tower kernel: br0: port 2(vnet0) entered blocking state
May 11 04:48:03 Tower kernel: br0: port 2(vnet0) entered forwarding state
May 11 04:48:04 Tower avahi-daemon[2006]: Joining mDNS multicast group on interface vnet0.IPv6 with address fe80::fc54:ff:fec3:3fc3.
May 11 04:48:04 Tower avahi-daemon[2006]: New relevant interface vnet0.IPv6 for mDNS.
May 11 04:48:04 Tower avahi-daemon[2006]: Registering new address record for fe80::fc54:ff:fec3:3fc3 on vnet0.*.
May 11 04:52:44 Tower ntpd[1761]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized
May 11 05:18:38 Tower avahi-daemon[2006]: Interface vnet0.IPv6 no longer relevant for mDNS.
May 11 05:18:38 Tower avahi-daemon[2006]: Leaving mDNS multicast group on interface vnet0.IPv6 with address fe80::fc54:ff:fec3:3fc3.
May 11 05:18:38 Tower kernel: br0: port 2(vnet0) entered disabled state
May 11 05:18:38 Tower kernel: device vnet0 left promiscuous mode
May 11 05:18:38 Tower kernel: br0: port 2(vnet0) entered disabled state
May 11 05:18:38 Tower avahi-daemon[2006]: Withdrawing address record for fe80::fc54:ff:fec3:3fc3 on vnet0.
May 11 05:25:33 Tower kernel: br0: port 2(vnet0) entered blocking state
May 11 05:25:33 Tower kernel: br0: port 2(vnet0) entered disabled state
May 11 05:25:33 Tower kernel: device vnet0 entered promiscuous mode
May 11 05:25:33 Tower kernel: br0: port 2(vnet0) entered blocking state
May 11 05:25:33 Tower kernel: br0: port 2(vnet0) entered forwarding state
May 11 05:25:34 Tower avahi-daemon[2006]: Joining mDNS multicast group on interface vnet0.IPv6 with address fe80::fc54:ff:fec3:3fc3.
May 11 05:25:34 Tower avahi-daemon[2006]: New relevant interface vnet0.IPv6 for mDNS.
May 11 05:25:34 Tower avahi-daemon[2006]: Registering new address record for fe80::fc54:ff:fec3:3fc3 on vnet0.*.

 

 

 

 

 

Edited by NoobCase
Link to post

I assume you're not attempting any video card pass through?

 

As @Vannie suggested, ports might be an issue - does the built in Unraid VM page "VNC Remote" feature give the same issues as standalone viewers?

When you get the blank screen are you still able to ping the VMs (or even connect to any shares that might exist)?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.