Jump to content
  • [6.11.5] Warning: file_put_contents(): Only -1 of 127 bytes written, possibly out of free disk space in.... Error, not able to access github

    • Solved Minor



    I am running v6.11.5 on a gen9 HPE dl380 with multiple spinning and ssd drives and 128gb of ecc ram. 


    In the last month or so I have noticed that I can't check plugins for updates, and community apps are unavailable due to the server not being able to reach git hub. When these issues pop up i see the following error on every page on the web interface 


    Warning: file_put_contents(): Only -1 of 127 bytes written, possibly out of free disk space in /usr/local/emhttp/plugins/dynamix/include/DefaultPageLayout.php on line 714


    If I reboot the server the error goes away for around a week or two then pops up again and things stop functioning as expected. 


    From what I am reading /usr/local is nonpersistent, so I'm guessing ram? I see an average of under 40% ram utilization.


    When I reboot due to the error, the reboot is flagged as unclear and kicks off a parity check 😞

    User Feedback

    Recommended Comments

    Will do.... I'm in the middle of yet another parity check currently, and it tends to take a week or two between occurrences so please don't make this closed etc! 


    And it looks like I have a failing drive (delayed writes in the millions during the parity check even though that drive wasn't touched).... So there will most likely be at least one more reboot in the middle, to replace the drive, before the error pops back up so realistically it could be weeks to a month before the error comes up again. Well actually 6 out of 9 spinning Disks with delayed reads, delayed writes and verification errors... Might have bigger fish to fry before I can update this thread 😞

    Edited by bilbo6209
    Link to comment

    OK disk issues appear to be sorted... hopefully


    I just started getting one of the symptoms of the "Warning: file_put_contents():" error... I just started getting errors saying the server cant access github. I can't update dockers. 

    The difference is I updated to 6.12.1 within the last week or so... maybe that is masking the original error?

    I can not start dockers (I tried to start Krusader to do some file maintenance), I receive a "execution error, server error" message

    I have attached diags taken after attempting to start several dockers


    after reboot everything is working correctly. I can start dockers, and access community apps


    Link to comment
    Filesystem      Size  Used Avail Use% Mounted on
    tmpfs            32M   32M     0 100% /run


    tmpfs is full, there have been some reports of this when running multiple containers, and some workarounds, search the forum and you should find them.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...