Jump to content
  • [6.12.10] Can't update docker container with port in URL

    • Minor



    Today I added a Docker Container that is on a custom Container Registry and not on DockerHub.

    The Registry is a Gitlab Registry hosted by my University.

    I've added the login credentials via the CLI and it worked without problems. I could add the Docker Container in the GUI and Unraid pulled and started it (almost) normally.


    I immediately noticed that on the Docker Page that for the container it showed "not available" for the version. So I made an update to the docker image (I'm pushing the updates so I know that there is one available), and tried to force the update via the advance view. But there it just showed my "TOTAL DATA PULLED: 0 B" and restarted the container. Of course the container was not updated.




    I then tried doing a docker pull in the CLI with the same URL as shown in the GUI and there it worked without a problem. As soon as I did the pull, I went back and retried the forced update, there of course, as excepted, it also pulled 0B and restarted the container with the new image since it now was present locally.




    So I think the Problem may be that the URL has a port after the domain and so the Unraid updater thinks the port and beyond is already the tag and not part of the URL anymore. If that is really the problem it should be easily fixed by looking for ":" on the far right instead of the first.


    The Diagnostic file was generated right after trying to update the container in the GUI so maybe there is something there that can help.



    • Upvote 1

    User Feedback

    Recommended Comments

    It's a pity that nothing happens here, unfortunately it doesn't work for me either. It seems that the GUI of UnRAID uses everything from a ":" as a tag.

    Edited by DjSni
    Link to comment

    Many improvements have been made to Docker since the original report. If you are still having the issue in Unraid 6.12.10, please post diagnostics and updated screenshots / details.

    Link to comment
    4 hours ago, ljm42 said:

    Many improvements have been made to Docker since the original report. If you are still having the issue in Unraid 6.12.10, please post diagnostics and updated screenshots / details.

    I've updated the screenshot and diagnostics with the one taken with version 6.12.10.


    The Problem persists. Also, I quickly looked trough the diagnostics files and couldn't see any log to the creation or update of the container so I don't know if it will help.

    Link to comment

    Thank you for your answer.

    Yes the problem still exists, it only exists in the GUI, in the CLI it works as it should.

    For example, the URL should look like this -> ghcr.io:443/nebn/unraid-simple-monitoring-api:latest

    UnRAID does this in the GUI:





    Link to comment

    Yes, it is most likely a very simple fix in adjusting the parser for the repository.


    For regex for example to change from 





    Or in other languages for example from find(':') to findr(':')

    Edited by [email protected]
    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...