Jump to content
  • SMB share using ZeroTier not working after 6.12.1 upgrade

    • Minor

    I have an SMB share using unassigned devices that is no longer working after the 6.12 upgrade. I'm using ZeroTier to bridge two unRaid servers on different networks together and they both have SMB shares to each other's media folders. Machine A can reach machine B shares just fine but machine B cannot reach machine A shares. Curious if anyone else has experienced this. Syslog and entire diagnostics zip attached.

    syslog.txt diagnostics.zip

    User Feedback

    Recommended Comments

    I changed the share on machine A from Secure to Private and now the share seems to be working. Maybe Secure shares break the SMB shares?

    Link to comment

    Share security operates on a different level and has no relation to connectivity.


    It is more likely your zerotier connection was not started properly, changing share security forces a service reload. Make sure you have followed the guidelines for setting up zeotier communication.


    Link to comment

    This problem is still occurring. ZeroTier configuration is working fine, as I am able to remotely administer unraid over ZeroTier.

    Here is the workflow:
    1. Add SMB share using unassigned devices
    2. Insert IP address of ZeroTier client

    3. Insert Share Credentials
    4. Hit Load Shares - Nothing Populates
    5. Manually Type in Share name and connect - can't mount 

    Issue is usually fixed temporarily after a reboot. Restarting ZeroTier container on both sides has no effect.

    Share from other machine coming into this one is working just fine.

    Link to comment

    Yes, both are running 6.12.2. Logs are unchanged. Don’t believe this is directly related to 6.12 upgrade, but not certain.


    It seems like smb share authentication is not working intermittently.

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...