Jump to content
  • unRAID 6.6.x SMB/NFS access issues


    Can0nfan
    • Annoyance

    I have noticed if a share has SMB (Private) and NFS (public) (possibly other configs) being accessed around the same time the user/ folder permissions break (forcing a reboot to restore) this was happening to me on constantly on 6.6 RC 4 and up. I ultimately went back to 6.5.3 where this issue doesn't happen and tried again with mention of an NFS fix in 6.6.1

    the setup I had to cause this was two unraid systems know as Sif (unraid plus) and Thor unraid pro and the system this was happening on

     

    Sif runs a Fedora VM that acts as a reverse proxy for some dockers that download content to Thor's Media Share. the Fedora VM mounts the /mnt/user/Media/Downloads folder with NFS
    Sif also is using unassigned devices to mount /mnt/user/Media with SMB

     

    after about 2 hours (on average) Plex on Thor crashes and doing an ls -l under /mnt/ on Thor shows this

     

    drwxrwxrwx  2 nobody users  40 Sep 30 01:59 disks/

    d?????????  ? ?      ?       ?            ? user/

    drwxrwxrwx  1 nobody users 139 Sep 30 02:09 user0/

     

    I found its totally stable once the unassigned devices mount was unmounted and a NFS version was created and mounted.

    this issue did not ever happen on 6.4.x and upto 6.5.3

    I posted logs before that showed NFS errors galore in the 6.6 RC forums
     

     



    User Feedback

    Recommended Comments

    2 minutes ago, limetech said:

    It's all the same bug man.

    yeah..just wondering if you got an update like working on it or still trying to find the root cause etc..

    Share this comment


    Link to comment
    Share on other sites

    The issue is that FUSE crashes which causes 'shfs' to crash which causes 'nfsd' to crash.

     

    Here is the code in FUSE (fuse.c) where the crash is occurring:

    static struct node *get_node(struct fuse *f, fuse_ino_t nodeid)
    {
            struct node *node = get_node_nocheck(f, nodeid);
            if (!node) {
                    fprintf(stderr, "fuse internal error: node %llu not found\n",
                            (unsigned long long) nodeid);
                    abort();
            }
            return node;
    }

    This function is being called with 'nodeid' 0, which is straight out of the NFS file handle.  That ‘abort()’ is what ultimately results in bringing down /mnt/user and along with it, nfsd.

     

    This is almost certainly due to a kernel change somewhere between 4.14.49 and 4.18.  Trying to isolate ...

    • Like 1

    Share this comment


    Link to comment
    Share on other sites


    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Guest
    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


  • Status Definitions

     

    Open = Under consideration.

     

    Solved = The issue has been resolved.

     

    Solved version = The issue has been resolved in the indicated release version.

     

    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.

     

    Retest = Please retest in latest release.


    Priority Definitions

     

    Minor = Something not working correctly.

     

    Urgent = Server crash, data loss, or other showstopper.

     

    Annoyance = Doesn't affect functionality but should be fixed.

     

    Other = Announcement or other non-issue.