bjun626

Members
  • Posts

    4
  • Joined

bjun626's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. You're correct the "peers.allowed_ips" are wrong on my remote side. As I'm using home assistant wireguard, so I have to manually add another field in its yaml configuration - allowed_ips: - 172.27.66.0/24 - 192.168.1.0/24 The reason I'm using the VPN tunneled access is because I'm trying to access from 192.168.1.0/24 to 192.168.0.0/24 and not the other way round. LAN to LAN also work for me. Thanks
  2. I reposted it on Cheers
  3. I've been trying to setup a tunnel to my other house's network. I've successfully setup to tunnel and I'm able to access my remote SMB on unraid. Right now I'm still unable to connect to the remote IP(192.168.0.0/24) from my own PC and docker containers in br0. What works: 1. Unraid -> Mount Remote SMB Share via Unassigned Device traceroute to 192.168.0.1 (192.168.0.1), 30 hops max, 60 byte packets 1 172.27.66.1 (172.27.66.1) 2.749 ms 2.742 ms 2.854 ms 2 * * * 3 192.168.0.1 (192.168.0.1) 3.642 ms 3.596 ms 3.595 ms 2. Docker not on br0 -> Able to ping 192.168.0.1 What doesn't work: 1. My PC 192.168.1.34 -> Unable to Ping 192.168.0.1 Tracing route to 192.168.0.1 over a maximum of 30 hops 1 1 ms 1 ms 2 ms [192.168.1.1] 2 2 ms 1 ms 1 ms [192.168.1.3] 3 * * * Request timed out. 2. Docker code-server 192.168.1.7 (br0) -> Unable to Ping 192.168.0.1 Below is my configuration Local: Router 192.168.1.1 - Static route 192.168.0.0/24 to 192.168.1.3 Unraid 192.168.1.3 (Using one one ethernet eth0 to router) - Wireguard: Set to "VPN tunnelled access" mode - Docker: "Host access to custom networks" is set to on Local Wireguard IP 172.27.66.4 Wireguard Subnet 172.27.66.0/24 Remote: Router 192.168.0.1 Remote Wireguard IP 172.27.66.1 Wireguard: - Hosted on RPi4 using homeassistant/wireguard (Should be in "Remote tunneled access" mode) What I observed is that unraid routing table is not routing my traffic to wg2 interface. Would like to know what changes should be done for my PC to able to connect to the remote subnet. Thanks
  4. I've been trying to setup a tunnel to my other house's network. I've successfully setup to tunnel and I'm able to access my remote SMB on unraid. Right now I'm still unable to connect to the remote IP(192.168.0.0/24) from my own PC and docker containers in br0. What works: 1. Unraid -> Mount Remote SMB Share via Unassigned Device traceroute to 192.168.0.1 (192.168.0.1), 30 hops max, 60 byte packets 1 172.27.66.1 (172.27.66.1) 2.749 ms 2.742 ms 2.854 ms 2 * * * 3 192.168.0.1 (192.168.0.1) 3.642 ms 3.596 ms 3.595 ms 2. Docker not on br0 -> Able to ping 192.168.0.1 What doesn't work: 1. My PC 192.168.1.34 -> Unable to Ping 192.168.0.1 Tracing route to 192.168.0.1 over a maximum of 30 hops 1 1 ms 1 ms 2 ms [192.168.1.1] 2 2 ms 1 ms 1 ms [192.168.1.3] 3 * * * Request timed out. 2. Docker code-server 192.168.1.7 (br0) -> Unable to Ping 192.168.0.1 Below is my configuration Local: Router 192.168.1.1 Unraid 192.168.1.3 (Using one one ethernet eth0 to router) Local Wireguard IP 172.27.66.4 Wireguard Subnet 172.27.66.0/24 Remote: Router 192.168.0.1 Remote Wireguard IP 172.27.66.1 What I observed is that unraid routing table is not routing my traffic to wg2 interface. Would like to know what changes should be done for the routing to be success Thanks