ZeroInputCtrl

Members
  • Posts

    30
  • Joined

  • Last visited

Converted

  • Gender
    Undisclosed

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

ZeroInputCtrl's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. I know Iperf3 is included in the pack but would it be possible to get Iperf2 added as well? The server I'm running single core performance isn't fast enough to test server to server over my 10g network. Iperf3 is single threaded vs iperf2 which has multi-threaded testing and would be useful.
  2. Can I get my username changed to ZeroInputCtrl please?
  3. I have tried other containers, everything behaves the same way when i move it over. If i move plexpy back to Bridge it works exactly how it should.
  4. Yes that is correct. It looks like there are settings under network that aren't be set? Maybe the creation of the bridge isn't working correctly? (although now that i look at plex (running as host) it looks almost the same...) root@Tower:~# docker inspect plexpy [ { "Id": "f435fe82cb968368d4bf303471451834b693f614e68cb56710f2e5680eca0c4f", "Created": "2017-08-01T13:11:30.14980889Z", "Path": "/init", "Args": [], "State": { "Status": "running", "Running": true, "Paused": false, "Restarting": false, "OOMKilled": false, "Dead": false, "Pid": 26869, "ExitCode": 0, "Error": "", "StartedAt": "2017-08-03T07:29:54.494827799Z", "FinishedAt": "2017-08-03T07:10:23.407953505Z" }, "Image": "sha256:549232ecfdafe38adaec000548eb3ae665587bb26b847bd182886afac8c81d89", "ResolvConfPath": "/var/lib/docker/containers/f435fe82cb968368d4bf303471451834b693f614e68cb56710f2e5680eca0c4f/resolv.conf", "HostnamePath": "/var/lib/docker/containers/f435fe82cb968368d4bf303471451834b693f614e68cb56710f2e5680eca0c4f/hostname", "HostsPath": "/var/lib/docker/containers/f435fe82cb968368d4bf303471451834b693f614e68cb56710f2e5680eca0c4f/hosts", "LogPath": "/var/lib/docker/containers/f435fe82cb968368d4bf303471451834b693f614e68cb56710f2e5680eca0c4f/f435fe82cb968368d4bf303471451834b693f614e68cb56710f2e5680eca0c4f-json.log", "Name": "/plexpy", "RestartCount": 0, "Driver": "btrfs", "MountLabel": "", "ProcessLabel": "", "AppArmorProfile": "", "ExecIDs": null, "HostConfig": { "Binds": [ "/mnt/user/appdata/plexmediaserver/Library/Application Support/Plex Media Server/Logs/:/logs:ro", "/mnt/user/appdata/plexpy:/config:rw" ], "ContainerIDFile": "", "LogConfig": { "Type": "json-file", "Config": {} }, "NetworkMode": "br0", "PortBindings": {}, "RestartPolicy": { "Name": "no", "MaximumRetryCount": 0 }, "AutoRemove": false, "VolumeDriver": "", "VolumesFrom": null, "CapAdd": null, "CapDrop": null, "Dns": [ "8.8.4.4" ], "DnsOptions": [], "DnsSearch": [], "ExtraHosts": null, "GroupAdd": null, "IpcMode": "", "Cgroup": "", "Links": null, "OomScoreAdj": 0, "PidMode": "", "Privileged": false, "PublishAllPorts": false, "ReadonlyRootfs": false, "SecurityOpt": null, "UTSMode": "", "UsernsMode": "", "ShmSize": 67108864, "Runtime": "runc", "ConsoleSize": [ 0, 0 ], "Isolation": "", "CpuShares": 0, "Memory": 0, "NanoCpus": 0, "CgroupParent": "", "BlkioWeight": 0, "BlkioWeightDevice": null, "BlkioDeviceReadBps": null, "BlkioDeviceWriteBps": null, "BlkioDeviceReadIOps": null, "BlkioDeviceWriteIOps": null, "CpuPeriod": 0, "CpuQuota": 0, "CpuRealtimePeriod": 0, "CpuRealtimeRuntime": 0, "CpusetCpus": "", "CpusetMems": "", "Devices": [], "DeviceCgroupRules": null, "DiskQuota": 0, "KernelMemory": 0, "MemoryReservation": 0, "MemorySwap": 0, "MemorySwappiness": -1, "OomKillDisable": false, "PidsLimit": 0, "Ulimits": null, "CpuCount": 0, "CpuPercent": 0, "IOMaximumIOps": 0, "IOMaximumBandwidth": 0 }, "GraphDriver": { "Data": null, "Name": "btrfs" }, "Mounts": [ { "Type": "bind", "Source": "/mnt/user/appdata/plexmediaserver/Library/Application Support/Plex Media Server/Logs", "Destination": "/logs", "Mode": "ro", "RW": false, "Propagation": "" }, { "Type": "bind", "Source": "/mnt/user/appdata/plexpy", "Destination": "/config", "Mode": "rw", "RW": true, "Propagation": "" } ], "Config": { "Hostname": "f435fe82cb96", "Domainname": "", "User": "", "AttachStdin": false, "AttachStdout": false, "AttachStderr": false, "ExposedPorts": { "8181/tcp": {} }, "Tty": false, "OpenStdin": false, "StdinOnce": false, "Env": [ "TZ=America/New_York", "HOST_OS=unRAID", "TCP_PORT_8181=8181", "PUID=99", "PGID=100", "PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin", "PS1=$(whoami)@$(hostname):$(pwd)$ ", "HOME=/root", "TERM=xterm" ], "Cmd": null, "ArgsEscaped": true, "Image": "linuxserver/plexpy", "Volumes": { "/config": {}, "/logs": {} }, "WorkingDir": "", "Entrypoint": [ "/init" ], "OnBuild": null, "Labels": { "build_version": "Linuxserver.io version:- 79 Build-date:- July-28-2017-22:58:27-UTC" } }, "NetworkSettings": { "Bridge": "", "SandboxID": "806c7c6a524a7b0cb7610309bf423c3260fc4a9b088704be6a462eed19b664d1", "HairpinMode": false, "LinkLocalIPv6Address": "", "LinkLocalIPv6PrefixLen": 0, "Ports": {}, "SandboxKey": "/var/run/docker/netns/806c7c6a524a", "SecondaryIPAddresses": null, "SecondaryIPv6Addresses": null, "EndpointID": "", "Gateway": "", "GlobalIPv6Address": "", "GlobalIPv6PrefixLen": 0, "IPAddress": "", "IPPrefixLen": 0, "IPv6Gateway": "", "MacAddress": "", "Networks": { "br0": { "IPAMConfig": { "IPv4Address": "192.168.1.136" }, "Links": null, "Aliases": [ "f435fe82cb96" ], "NetworkID": "a1eef7a753830ae0152455418dcabfd2701e7e5c59a9f56f6c24ed2a28792ccf", "EndpointID": "bcbc67489b78c801c02f7cf5c35ff3b924496915d08808cc7ff73a9e6eccc303", "Gateway": "192.168.1.1", "IPAddress": "192.168.1.136", "IPPrefixLen": 24, "IPv6Gateway": "", "GlobalIPv6Address": "", "GlobalIPv6PrefixLen": 0, "MacAddress": "02:42:c0:a8:01:88" } } } } ]
  5. The first line seems odd to me root@f435fe82cb96:/$ arp -an ? (192.168.1.100) at <incomplete> on eth0 ? (192.168.1.1) at 44:d9:e7:9f:94:ed [ether] on eth0
  6. Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
  7. Basically the same thing, 1 extra hop i guess traceroute to 192.168.1.1 (192.168.1.1), 30 hops max, 46 byte packets 1 * * f435fe82cb96 (192.168.1.136) 3053.394 ms !H 2 f435fe82cb96 (192.168.1.136) 3071.979 ms !H 3071.922 ms !H 3071.956 ms !H
  8. I think this is an accurate representation, http://prntscr.com/g3hd61
  9. I've had this happen, make sure your configuration for the container is setup correctly. I've had times when messing with a network interface, any containers that were using that would throw this error until i moved them onto a network that existed.
  10. I was also talking with a friend and comparing against his setup (he is also on rc7a). And the only meaningful difference we can maybe see is that i'm using more that one nic. Just for some more information. This is the mobo i'm using, https://www.supermicro.com/products/motherboard/QPI/5500/X8DTN_.cfm?IPMI=O Also when running a traceroute from my container i get this. 100 is my server and 136 is my container ip address. root@f435fe82cb96:/$ traceroute 192.168.1.100 traceroute to 192.168.1.100 (192.168.1.100), 30 hops max, 46 byte packets 1 f435fe82cb96 (192.168.1.136) 3064.843 ms !H 3071.870 ms !H 3072.011 ms !H Current route from docker Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default 192.168.1.1 0.0.0.0 UG 211 0 0 br0 default 192.168.2.1 0.0.0.0 UG 212 0 0 br1 172.17.0.0 * 255.255.0.0 U 0 0 0 docker0 192.168.1.0 * 255.255.255.0 U 0 0 0 br0 192.168.2.0 * 255.255.255.0 U 0 0 0 br1 container route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0 192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
  11. So I deleted/recreated my docker.img and the errors above went away but i'm still having all the same issues as mentioned in the OP.
  12. So I've tried turning off bridge for eth1 nothing shows up in the networks for docker (original behavior correct?). I turned both my interfaces to bridge and they stopped showing up. I took a look at my docker log and now i'm getting these errors. As you can see it's telling me that there are networks already using those interfaces but when i pull "docker network ls" there are no network id's that match that.... are there some files that are cached somewhere that I can purge? I've rebuilt my docker.img since i've upgraded to 6.4 Start of the log is me shutting down docker to change network settings. There is nothing in the syslog. time="2017-07-31T18:43:20.075034381-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.8: invalid argument" time="2017-07-31T18:44:04.737061423-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.2: invalid argument" time="2017-07-31T18:44:06.579377013-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.6: invalid argument" time="2017-07-31T18:44:08.248703579-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.7: invalid argument" time="2017-07-31T18:44:08.393078869-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.10: invalid argument" time="2017-07-31T18:44:08.507116467-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.11: invalid argument" time="2017-07-31T18:44:08.576536537-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.12: invalid argument" time="2017-07-31T18:44:08.621472377-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.9: invalid argument" time="2017-07-31T18:44:08.742331480-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.3: invalid argument" time="2017-07-31T18:44:08.811979489-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.5: invalid argument" time="2017-07-31T18:44:09.024326703-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.13: invalid argument" time="2017-07-31T18:44:14.634943207-04:00" level=info msg="Container b3c674c37fd61664b6efba3f108dfa13c60e7215fec6654eb032a1c2520c9761 failed to exit within 10 seconds of signal 15 - using the force" time="2017-07-31T18:44:14.748168630-04:00" level=warning msg="Failed to delete conntrack state for 172.17.0.4: invalid argument" time="2017-07-31T18:44:14.954534902-04:00" level=info msg="Processing signal 'terminated'" time="2017-07-31T18:44:14.989943836-04:00" level=info msg="stopping containerd after receiving terminated" time="2017-07-31T18:44:54.872534406-04:00" level=info msg="libcontainerd: new containerd process, pid: 2824" time="2017-07-31T18:44:55.874409700-04:00" level=warning msg="failed to rename /var/lib/docker/tmp for background deletion: %!s(<nil>). Deleting synchronously" time="2017-07-31T18:44:55.936539087-04:00" level=info msg="Graph migration to content-addressability took 0.00 seconds" time="2017-07-31T18:44:55.937325073-04:00" level=info msg="Loading containers: start." time="2017-07-31T18:44:56.110870758-04:00" level=info msg="Default bridge (docker0) is assigned with an IP address 172.17.0.0/16. Daemon option --bip can be used to set a preferred IP address" time="2017-07-31T18:44:56.233074747-04:00" level=info msg="Loading containers: done." time="2017-07-31T18:44:56.251059344-04:00" level=info msg="Daemon has completed initialization" time="2017-07-31T18:44:56.251103739-04:00" level=info msg="Docker daemon" commit=89658be graphdriver=btrfs version=17.05.0-ce time="2017-07-31T18:44:56.268290591-04:00" level=info msg="API listen on /var/run/docker.sock" time="2017-07-31T18:44:56.358543624-04:00" level=error msg="Handler for POST /v1.29/networks/create returned error: network dm-773d138ba3e6 is already using parent interface br0" time="2017-07-31T18:44:56.380154436-04:00" level=error msg="Handler for POST /v1.29/networks/create returned error: network dm-c7555e2612a5 is already using parent interface br1" 992b7902c5d3 bridge bridge local 6e67adb42099 host host local f8dd7760ee84 none null local
  13. No rules that block outbound traffic, nothing of note has been changed on the router since I upgraded to 6.4. Here are my routes (all generated by unraid). Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default 192.168.1.1 0.0.0.0 UG 100 0 0 br0 172.17.0.0 * 255.255.0.0 U 0 0 0 docker0 192.168.1.0 * 255.255.255.0 U 0 0 0 br0 192.168.2.0 * 255.255.255.0 U 0 0 0 eth1
  14. gui works fine, "ping 192.168.1.1" doesn't work, nor can i "curl google.com", dns resolution fails.