Tergi

Members
  • Posts

    15
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Tergi's Achievements

Newbie

Newbie (1/14)

5

Reputation

  1. yes, it is best to watch your logs when you connect the printer and see what device file is assigned to the printer and video devices.
  2. Hey printer friends, I have another update. Took on the upgrade octoprint task while maintaining webcam. It was rather easy. I deleted the nunofgs docker for octoprint. I searched community apps for octoprint, selected the docker hub images, found the octoprint/octoprint official docker image. I installed it and configured the template you see in the image attached. I have not figured out how to submit a template to community apps, so for now this should do. I'm not sure 100% if anything might be missing or need a tweak. Let me know how you make out. Note: i did use pretty much all the same values as before. I used the same config folder as the old one. It accepted the configs and everything came right up and all I had to do was create an account. Plugins were all blown away. So you will have to reload all those.
  3. Hi @sloppy, I am using his default install. I am not doing as much 3d printing as i used to. The octoprint has an updater in it... when i tried it once it blew up everything. if you try it, then you will probably want to backup your configs.
  4. Thank you , that might have been the part i missed. I got 1 announcement in my channel last night. I will keep tracking it. thanks. One small request, can the log file be time stamped per entry? Currently the logs just list out all the events that happen but we dont know when they happened. Might also be nice to have a debug option for the log that dumps all the data that goes to discord in the log also. At least the title. Thanks!
  5. Thanks for the fix on the URL thing. Everything "looks" correct in my settings. I get notices saying that a request came in but never one that is when a movie is added. I checked the discord URL also and it is correct. Pause/Play triggers incoming requests which it is ignoring but i do not see anything related to the movie getting added. The movie comes from radarr.
  6. Hello, I have the plex end of this configured and i get the inbound request messages. However when a new video does arrive in the server it does not go to discord. Also, when i copy the discord webhook url from discord channel and paste it into the template config the docker exits and the logs indicate: Invalid discord webhook url Falling back to manual discord webhook configuration discord_webhook_id is not defined I noticed that in your example the domain for discord is not the same as the one discord is using. I modified the domain to the same as your example and it was accepted and starts. I still do not get the notifications in discord however. The channel I'm using this in is a private invite only channel, but i don't think that should matter. I have other webhook bots that are able to post to restricted channels like this. Here is how the domain is in the webhook URL copied from my discord client i trimmed the important bits off the end: https://discordapp.com/api/webhooks/
  7. For those who may not know now that 6.9 is out the DVB stuff is a plugin and can be found by searching the APPs tab for "dvb drivers". There is also a section on the left for drivers that will filter down everything to just plugin based drivers. I updated to 6.9 and installed this and restarted and everything just worked without issue. This is mentioned in previous comments here also but figured I would at least mention that it does work for the needs of octoprint and is pretty much a one click solution now.
  8. You might need to verify that the drivers support that webcam. It has been a while since i looked at any of this so i don't remember exactly but there might be a command for v4l that prints out any cams it can work with that are attached to the PC. I know in my case as long as unraid is booted the cam is active.
  9. Mine did change the video device number a few times between 0 and 1 so I would check that. If no video device then check lsusb and see if it shows up there. If not the verify the USB cable is good.
  10. LibreElect is a custom built Kernel for UnRaid that includes drivers that are missing that you need for use with cameras and different video devices. I think alot of time they are used for people with TV tuners that want to use their UnRaid box to record live broadcast tv and such, and or security cameras and things like that. I am not sure. I just know that it includes Video 4 Linux which is what i needed to get my webcam working You can get it in community apps by finding Unraid DVB by linux server folks. its a plugin. it will do the replacement of the Kernel. there are a few flavors. The one i used is mentioned as you have seen. You can go up to kernel version 6.8.3 at this moment in time. Once it loads it and you reboot unraid it should start loading your camera device drivers.
  11. If you can get the snapshot you should be able to get the stream also. I was talking to someone about similar issues and they said using the port i used in my container fixed the problem for them. I don't know why that would be the case but it was what they said worked. I used 8999. You should be able to access the stream directly using this URL (replace your unraid server IP and port number.) http://192.168.2.1:8999/webcam/?action=stream Also, you can strip off the ?action stuff at the end and you should get right to the webcam webserver and see both the stream and snapshot functions. I also changed the stream settings inside octoprint also. In settings under webcam & timelapse, i changed the Snapshot URL to: http://127.0.0.1/webcam/?action=snapshot and the Stream URL to http://192.168.2.1:8999/webcam/?action=stream (obviously using my own unraid IP and port.
  12. I was able to resolve this finally. the issue was drivers as i suspected. Video 4 Linux was needed. I was able to find this driver set in the LinuxServer.IO plugin for DVB. i used the LibreElec release on the latest 6.8.2 kernel they offer. I am now .1 version behind but i am able to do what i need to do with the webcam. after installing that plugin and downloading the LibreElect 6.8.2 release i rebooted. I then have 2 /dev/video0 and dev/video1 devices. only /dev/video0 works. Passing this into the docker similar to above replacing the /dev/bus stuff with /dev/video0 was what i needed to get this going. Hope that this helps someone in the future.
  13. I an trying to pass a Logitech C920 webcam into docker for use with Octoprint. When i plug the camera in, the dmesg shows the usb device getting connected, gives it a number etc. It does not generate a /dev/<thing> entry on the file system however. lsusb lists it as a device and you can go into /dev/bus/usb/001/00x and see it but i don't think this device actually works. I passed this device into the docker container and set the env variable. i see the device show up in the docker container per my passed in device... and i see the log for the container say it tries to access the device for the camera but it says it cannot read the device and then fails to initialize the video. So at this point im not sure what i am missing. Is there a kernel module/drive missing somewhere? Is it a permissions issue? Other config issue? If anyone has any idea's i would appreciate it. Thank you! Docker Container I'm using: https://hub.docker.com/r/nunofgs/octoprint/ I did define the env variable for the camera device to point to the same as the device i define in the docker config also. Solution to the above problem is outlined here in this document: https://docs.google.com/document/d/1oWM8q1r5BXgLz3lnwuqXf07zzdHpq5LuMxk4nvFjtzs/edit?usp=sharing Further down in this thread there is the old way which used a plugin for unraid called Unraid DVB. it was discontinued. This process uses more effort on our part but is not that terribly hard to complete. You may wish to read through the remainder of this thread anyway to catch any additional info that might be helpful.
  14. Ok, so you mean to use the full url /#/whatever? like you get when you use unraid "web Ui" menu item? If i use: proxy_pass http://192.168.2.1:9080/#/client/c/Calibre; i get 404 from apache tomcat. if i use: proxy_pass http://192.168.2.1:9080/#/client/c/Calibre/; i get 404 from apache tomcat still. If its tomcat reporting back i think that means i am hitting the container because organizr and letsencrypt use nginx.
  15. What settings are folks using to reverse proxy the rdp gui? I cannot seem to get it to work and im not sure what is my issue. I cannot find any errors. accessing the domain and subdir https://domain.com/calibre fails with a blank screen. no console errors, no errors on the container logs, no errors on the letsencrypt log. i dont get it. here is what i have: #RDPCalibre Container location /calibre { #auth_request /auth-1; #=Co-Admin proxy_pass http://192.168.2.1:9080/; include /config/nginx/proxy.conf; } proxy contains: ## Version 2018/05/31 - Changelog: https://github.com/linuxserver/docker-letsencrypt/commits/master/root/defaults/proxy.conf client_max_body_size 10m; client_body_buffer_size 128k; #Timeout if the real server is dead proxy_next_upstream error timeout invalid_header http_500 http_502 http_503; # Advanced Proxy Config send_timeout 5m; proxy_read_timeout 240; proxy_send_timeout 240; proxy_connect_timeout 240; # Basic Proxy Config proxy_set_header Host $host:$server_port; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto https; proxy_set_header X-Forwarded-Host $host; proxy_set_header X-Forwarded-Ssl on; proxy_redirect http:// $scheme://; proxy_http_version 1.1; proxy_set_header Connection ""; #proxy_cookie_path / "/; HTTPOnly; Secure"; # enable at your own risk, may break certain apps proxy_cache_bypass $cookie_session; proxy_no_cache $cookie_session; proxy_buffers 32 4k; anyone have any thoughts or working examples? thanks!