bulletjie

Members
  • Posts

    8
  • Joined

  • Last visited

bulletjie's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Hi have actually solved my issue. I removed the letsencrypt container and app folder, reinstalled and now it is working! hoorray
  2. Failed to load resource: the server responded with a status of 521 ()
  3. I cannot reach the log in page from any of my devices: I would really appreciate if someone can help me troubleshoot my issue. I can reach https://bw.mydomain.com/admin But I cannot reach the log in page, I only get as far as the banner and spinning circle The nginx error log file reveals a error and I don't know how to fix it The access log file shows these requests were passed through In pfSense I have the following port forwarding set up My nginx conf file looks like this: #BITWARDEN # make sure that your domain has dns has a cname or a record set for the subdomain bitwarden # This config file will work as is when using a custom docker network the same as letesencrypt (proxynet). # However the container name is expected to be "bitwardenrs" as it is by default the template as this name is used to resolve. # If you are not using the custom docker network for this container then change the line "server bitwardenrs:80;" to "server [YOUR_SERVER_IP]:8086;" Also remove line 7 server { listen 80; server_name bw.*; return 301 https://$server_name$request_uri; } server { listen 443 ssl http2; # listen [::]:443 ssl; server_name bw.*; include /config/nginx/ssl.conf; client_max_body_size 128M; location / { # include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; proxy_pass http://10.10.20.50:8086; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; } location /notifications/hub { resolver 127.0.0.11 valid=30s; proxy_pass http://10.10.20.50:3012; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; } location /notifications/hub/negotiate { resolver 127.0.0.11 valid=30s; proxy_pass http://10.10.20.50:8086; } }
  4. Did you go to your google account and created a new App password? If you you 2-step verification then this is the way to get bitwarden to log in to your gmail account. https://myaccount.google.com/apppasswords
  5. I cannot get onto the bitwarden login page when accessing it via the domain I've set up. I edited the conf file by inserting my domain name and saved it to the correct folder as spaceinvaderone instructs. Letsencrypt works correctly as I am self hosting a website on my server. I think there may be a problem with the config file? Any ideas? BTW I can access bitwarden correctly via ip address of my server. I also run pfsense, so could it be a port forwarding issue? #BITWARDEN # make sure that your domain has dns has a cname or a record set for the subdomain bitwarden # This config file will work as is when using a custom docker network the same as letesencrypt (proxynet). # However the container name is expected to be "bitwardenrs" as it is by default the template as this name is used to resolve. # If you are not using the custom docker network for this container then change the line "server bitwardenrs:80;" to "server [YOUR_SERVER_IP]:8086;" Also remove line 7 resolver 127.0.0.11 valid=30s; upstream bitwarden { server bitwardenrs:80; } server { listen 443 ssl; server_name bw.myserver.com; include /config/nginx/ssl.conf; client_max_body_size 128M; location / { proxy_pass http://bitwarden; proxy_set_header Host $host; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; } location /notifications/hub { proxy_pass http://bitwarden; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection "upgrade"; } location /notifications/hub/negotiate { proxy_pass http://bitwarden; } }
  6. Yes I did, and since my post I enabled the additional lines and included the include and resolver lines as per the previous post but no luck. Bitwarden seems to work as when sync from my phone and using the webUI but I cannot get past the spinning wheel when trying to log in using the domain name. Could it be a firewall issue? I use pfsense btw.
  7. # make sure that your dns has a cname set for sonarr and that your sonarr container is not using a base url server { listen 80; server_name bw.*; return 301 https://$server_name$request_uri; } server { listen 443 ssl; server_name bw.*; # add_header X-Content-Type-Options nosniff; # add_header X-XSS-Protection "1; mode=block"; # add_header Referrer-Policy same-origin; include /config/nginx/ssl.conf; client_max_body_size 0; location / { # auth_basic "Restricted"; # auth_basic_user_file /config/nginx/.htpasswd; include /config/nginx/proxy.conf; resolver 127.0.0.11 valid=30s; set $upstream_bitwarden bitwarden; proxy_pass http://$upstream_bitwarden:80; proxy_set_header Host $host; # proxy_ssl_server_name on; proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_set_header X-Forwarded-Proto $scheme; # proxy_headers_hash_bucket_size 512; } # location /notifications/hub { # proxy_pass http://10.10.20.50:3012; # proxy_set_header Upgrade $http_upgrade; # proxy_set_header Connection "upgrade"; # } # location /notifications/hub/negotiate { # proxy_pass http://10.10.20.50:8343; # } } Can someone please help. I cannot get pass the loading page from my web browser using reverse proxy. Logging in via webUI and connecting with my bitwarden on my phone works correctly. I notice a error in log file whenever I try access my bw subdomain