sfnetwork

Members
  • Posts

    31
  • Joined

  • Last visited

sfnetwork's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hi guys, I'm sorry if this seems repetitive but I'm a little confused trying to link what I'm reading here with my issue. Pretty sure my issue is related to the PIA server changes but can't figure out anything further... Only when I try using the PIA VPN, I get those logs: 2020-09-16 08:57:29,119 DEBG 'start-script' stdout output: [info] PIA endpoint 'ca-toronto.privateinternetaccess.com' is in the list of endpoints that support port forwarding 2020-09-16 08:57:29,119 DEBG 'start-script' stdout output: [info] List of PIA endpoints that support port forwarding:- [info] ca-toronto.privateinternetaccess.com [info] ca-montreal.privateinternetaccess.com [info] ca-vancouver.privateinternetaccess.com [info] de-berlin.privateinternetaccess.com [info] de-frankfurt.privateinternetaccess.com [info] france.privateinternetaccess.com [info] czech.privateinternetaccess.com [info] spain.privateinternetaccess.com [info] ro.privateinternetaccess.com [info] israel.privateinternetaccess.com [info] Attempting to get dynamically assigned port... 2020-09-16 08:57:29,123 DEBG 'start-script' stdout output: [info] Attempting to curl http://209.222.18.222:2000/?client_id=82c6286e81c68d1290dd70c7a466b537ce08a98822f4970c4651a95bca52e3b0... 2020-09-16 08:57:29,150 DEBG 'start-script' stdout output: [warn] Response code 000 from curl != 2xx [warn] Exit code 56 from curl != 0 [info] 12 retries left [info] Retrying in 10 secs... 2020-09-16 08:57:39,234 DEBG 'start-script' stdout output: [warn] Response code 000 from curl != 2xx [warn] Exit code 56 from curl != 0 [info] 11 retries left [info] Retrying in 10 secs... I've read to try changing servers but no clue how to do that (there is the "name server" field but it only seems to take IPs. I already have several in there but not sure what to change it for... When I disable VPN, qbittorrent run fine... My PIA account works fine still... I'm a little lost...
  2. Update: never mind, I simply had to delete the "transcode" folder in /TMP so it recreated it (with correct permissions I presume) It works fine now
  3. Hi, after all that, the only thing not working anymore is the transcode folder... I had "/transcode" mapped to /TMP (RAM) but now, it always gives me an error when transcoding is needed: I tested changing it to an actual share and it works... Permission issue? I looked at the console and saw those errors: LevelError Thread0x1494699ec700 MessageError configuring transcoder: TPU: Failed to write sub-stream to temporary file TimeApr 17, 2019 08:37:35.243 LevelError Thread0x1494699ec700 MessageError creating directory "/transcode/Transcode/Sessions/plex-transcode-23AA3EAB-F829-4746-8E92-AFA7D48DB98C-c1d708e7-b92e-4595-967a-49ea7e860af4": boost::filesystem::create_directory: Permission denied: "/transcode/Transcode/Sessions/plex-transcode-23AA3EAB-F829-4746-8E92-AFA7D48DB98C-c1d708e7-b92e-4595-967a-49ea7e860af4"
  4. thank you very much it worked! I stopped to container, install this one from CA and set it up the exact same way for the paths , appdata assignment and name. It ran a permission process and it started without error and up to date.
  5. Yeah, I tried that already, same error... PS. in case it matters, a while back I changed from official plex to this one by just changing the repository, it was working fine though and updating... Could there be a setting from the other container causing me this issue?
  6. same issue here... Is there a work around to update or should I temporary switch to another source in meantime?
  7. ok I got it, I had to comment the auth_basic lines, it works perfectly now! server { listen 443 ssl http2; listen [::]:443 ssl http2; root /config/www; index index.html index.htm index.php; server_name nvr.*; include /config/nginx/ssl.conf; client_max_body_size 0; location / { # auth_basic "Restricted"; # auth_basic_user_file /config/nginx/.htpasswd; include /config/nginx/proxy.conf; proxy_pass http://192.168.1.149:88; } }
  8. ok, it works when I set the password but if I comment it or delete its content, the https URL still prompts me for credentails... any way to bypass it?
  9. No, not at all... Is that to protect the site or if the site has a password itself? Not optional? Looked optional "If you'd like to password protect your sites, you can use htpasswd."
  10. Hi again, I have something different I want to do but not sure how... I'm trying to use Nginx to login to my Hikvision NVR using HTTPS, not a docker so a little different... I created the sub domain name, successfully added it in Letsencrypt and for nginx, what I did (and I'm really not sure this is the correct way) is to create a file named "nvr" and added this in it: server { listen 443 ssl http2; listen [::]:443 ssl http2; root /config/www; index index.html index.htm index.php; server_name nvr.*; include /config/nginx/ssl.conf; client_max_body_size 0; location / { auth_basic "Restricted"; auth_basic_user_file /config/nginx/.htpasswd; include /config/nginx/proxy.conf; proxy_pass http://192.168.1.149:88; } } When I restart everything and test I get : 403 Forbidden nginx/1.14.2 and in logs, I get: 2019/03/16 21:18:10 [error] 358#358: *1 open() "/config/nginx/.htpasswd" failed (2: No such file or directory), client: 192.168.1.254, server: nvr.*, request: "GET / HTTP/2.0", host: "nvr.mydomain.com" 2019/03/16 21:18:10 [error] 358#358: *1 open() "/config/nginx/.htpasswd" failed (2: No such file or directory), client: 192.168.1.254, server: nvr.*, request: "GET /favicon.ico HTTP/2.0", host: "nvr.sfnetwork.ca", referrer: "https://nvr.mydomain.com/" Anything obvious to resolve this? Maybe I'm not doing this the correct way too... Thanks in advanced...
  11. Good. Still wonder why it wasn’t working the way you had it. Did you test from outside your network? Typing the http URL?
  12. Really looks like port 80 is blocked. You could confirm it by forwarding 80 to anything in your LAN (or use a tool that listen on the port you want) and really see. That’s how I confirmed my port 80 was blocked after my ISP also told me it wasn’t. I called them back and they finally confirmed it was. They told me usually, even commercial accounts, if you don’t have a static IP, 80 is blocked. Well for my ISP. But based on the fact your 443 works and seems to be setup the same as 80, would bet it’s blocked.