Jump to content

Kingedgar

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Kingedgar

  • Rank
    Newbie
  1. Hello, I currently have an issue where I lost all network connectivity on the default docker bridge and all but one user defined network. I'm not sure where else to go but here are some commands I have used to try to diagnose. root@igbrain:~# docker run --rm busybox ip addr 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever 2: tunl0@NONE: <NOARP> mtu 1480 qdisc noop qlen 1000 link/ipip 0.0.0.0 brd 0.0.0.0 3: gre0@NONE: <NOARP> mtu 1476 qdisc noop qlen 1000 link/gre 0.0.0.0 brd 0.0.0.0 4: gretap0@NONE: <BROADCAST,MULTICAST> mtu 1462 qdisc noop qlen 1000 link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff 5: erspan0@NONE: <BROADCAST,MULTICAST> mtu 1450 qdisc noop qlen 1000 link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff 6: ip_vti0@NONE: <NOARP> mtu 1480 qdisc noop qlen 1000 link/ipip 0.0.0.0 brd 0.0.0.0 7: sit0@NONE: <NOARP> mtu 1480 qdisc noop qlen 1000 link/sit 0.0.0.0 brd 0.0.0.0 62: eth0@if63: <BROADCAST,MULTICAST,UP,LOWER_UP,M-DOWN> mtu 1500 qdisc noqueue link/ether 02:42:ac:11:00:04 brd ff:ff:ff:ff:ff:ff inet 172.17.0.4/16 brd 172.17.255.255 scope global eth0 valid_lft forever preferred_lft forever root@bigbrain:~# docker run --rm busybox ip route show default via 172.17.0.1 dev eth0 172.17.0.0/16 dev eth0 scope link src 172.17.0.4 root@bigbrain:~# docker run --rm busybox cat /etc/resolv.conf # Generated DNSv4 entries: nameserver 8.8.8.8 nameserver 8.8.8.4 root@bigbrain:~# docker run --rm busybox ping -c 4 4.2.2.2 PING 4.2.2.2 (4.2.2.2): 56 data bytes --- 4.2.2.2 ping statistics --- 4 packets transmitted, 0 packets received, 100% packet loss root@bigbrain:~# docker run --rm busybox nslookup google.com ;; connection timed out; no servers could be reached root@bigbrain:~# Unraid box as far as I can tell has the proper route. The only network that works is the one I created using the following: docker network create --driver=bridge --ip-range=192.168.0.64/27 --subnet=192.168.0.0/24 --gateway=192. 168.0.20--attachable -o "com.docker.network.bridge.name=br0" --aux-address="DefaultGatewayIPv4=192.168.0.1" br0 Any help is appreciated! bigbrain-diagnostics-20190509-0914.zip