Jump to content

xTxHiLLx

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About xTxHiLLx

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I'd like some input on something I haven't been able to fix. On qbittorrent download completion, I am running this command: cd /mnt/user/downloads/%N/; /usr/bin/unrar e *.rar I am doing this so sonarr/radarr picks up files where rar's are present, it will unrar it in the directory so it can picked up/moved. In qbittorent logs, I see it getting executed: Torrent: Zombieland.Double.Tap.2019.1080p.BluRay.x264-DRONES, running external program, command: cd /mnt/user/downloads/Zombieland.Double.Tap.2019.1080p.BluRay.x264-DRONES/; /usr/bin/unrar e *.rar However, unrar is not running and no file gets created in the directory. But, I login via terminal and manually run the following from any directory it works: cd /mnt/user/downloads/Zombieland.Double.Tap.2019.1080p.BluRay.x264-DRONES/; /usr/bin/unrar e *.rar Anyone have any guesses? It could be a permissions issue. Is there a way I can increase debugging for qbittorrent to see if catches anything?
  2. Hey guys. Need a hand with something. I am running this command on torrent completion from qbitt: /usr/bin/unrar e /mnt/user/downloads/%N/*.rar Basically when radarr or sonarr downloads something with an rar archive, I am using unrar to try and get it to auto extract so they can pick up the file and move it accordingly. However it doesnt seem to work. This is for the qbitt log file: (N) 2019-11-20T22:04:02 - Download first and last piece first: Off, torrent: 'The.Goldfinch.2019.1080p.BluRay.x264-GECKOS' (N) 2019-11-20T22:04:02 - 'The.Goldfinch.2019.1080p.BluRay.x264-GECKOS' added to download list. (N) 2019-11-20T22:05:54 - Torrent: The.Goldfinch.2019.1080p.BluRay.x264-GECKOS, running external program, command: /usr/bin/unrar e /mnt/user/downloads/The.Goldfinch.2019.1080p.BluRay.x264-GECKOS/*.rar However, there is no .mkv in the directory. But, if I manually run from the terminal: /usr/bin/unrar e /mnt/user/downloads/The.Goldfinch.2019.1080p.BluRay.x264-GECKOS/*.rar I get: ... The.Goldfinch.2019.1080p.BluRay.x264-GECKOS.mkv Inappropriate ioctl for device Write error in the file The.Goldfinch.2019.1080p.BluRay.x264-GECKOS.mkv [R]etry, [A]bort r So, then i cd into the directory itself and manually run: unrar e *.rar And it works fine. Any ideas? Should I try something like: cd /mnt/user/downloads/%N/ && /usr/bin/unrar e *.rar
  3. Yes. My bad. Its my main source of playback for media inside my home. Hard wired into network. Run plex client on it. I honestly got a little aggravated when I saw this about the roku. But, it's a little strange that plex spikes like that if its not transcoding. It's usually only in the beginning. That is one thing I did after posting. I downloaded Dynamix SSD to execute trimming on a daily basis in quiet hours and changed the mover to daily at 2am. You know. This is something I may humor. I don't really see a point after you said this. I have a 500GB ssd. Only bad thing is I seed for a max of 7 days per some private trackers requirements. But, not using mover saves the disk space temporarily on the array and puts the array threw less writes. I may actually do this. I can also execute the mover manually if I need to. Lastly, something I realized is LIVE TV on plex is a CPU and Network hog. Transcoding to MPEG2 and streaming it on average of around 18mbps. And, with my tuner, I can't change the quality. I am a power user. At most, I could have 2 remote users streaming at 4mbps (both transcoding). A local stream at 20-40mbps. Usually direct play or stream. Sometimes transcoding. And, I usually have a local live tv session watching football. So, I have to figure out if I am saturating my network or if unraid is just consumed with so much writing/reading that my hardware or OS is having issues keeping up. I didn't have issues on windows. However, the PC had an NVME ssd running windows and plex/transcoding and I had another dedicated SSD for downloading and a RAID 5 array for media data.
  4. Hey guys. I need some help. I have been having some performance issues sporadically with plex since migrating to unraid from windows. I'm running binhex plex pass version. My main source of media is my roku ultra (LAN). I am having buffering issues with direct play, direct stream, and transcoding on the roku ultra. Plex reported all of them around 40-44mbps HOWEVER I did see spikes up to 115mbps occasionally. My server's mobo has gbps ethernet. It is connected to a gbps switch. The mentioned roku ultra is connected to the same gigabit switch. I just realized the roku ultra's ethernet port is only 100mbps. I get a message saying "the server is not powerful enough to convert video" which doesn't make any sense. I am running a 2600x and 16gb of ram. I have looked at plex logs and couldn't see anything but I am only looking at the console. All of my dockers run on the cache (SSD). Transcoding happens on the cache. Plex config is set to privileged. I restarted all the dockers. I even restarted the server. I have a suspicion its the SSD cache drive. Just because it started happening when I was trying to watch a movie, I was transcoding a remote stream to family, I was downloading files to the cache, and I believe I caught the mover running all at the same time because I have it set to hourly. I see this in the server's debugs: Oct 27 18:24:23 Kratos kernel: pcieport 0000:00:01.3: AER: Corrected error received: 0000:00:00.0 Oct 27 18:24:23 Kratos kernel: pcieport 0000:00:01.3: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID) Oct 27 18:24:23 Kratos kernel: pcieport 0000:00:01.3: device [1022:1453] error status/mask=00000040/00006000 Sorry for the book. I am just trying to get this figured out. Any recommendations are appreciated.
  5. Unraid Newb here. I recently setup a fully automated experience with Plex, Sonarr, Radarr, qbittorrent, and Jackett. I have qbittorrent set to automatically remove torrents after either a 1:1 ratio or after 7 days (to fulfill all tracker seeding requirements). However, I noticed its removing the torrent from qbitt but not removing it from /mnt/user/downloads. So I downloaded CA User Scripts and wrote a one liner to handle this: sudo find /mnt/user/downloads/ -mtime +7 -exec rm -rf {} \; Is there a better way to do this? Its preferable to remove the file in /mnt/user/downloads by the downloader. Does anyone know if qbittorent can be configured to do this or if rtorrent does this?
  6. Unraid Newb here. I recently setup a fully automated experience with Plex, Sonarr, Radarr, qbittorrent, and Jackett. I have qbittorrent set to automatically remove torrents after either a 1:1 ratio or after 7 days (to fulfill all tracker seeding requirements). However, I noticed its removing the torrent from qbitt but not removing it from /mnt/user/downloads. So I downloaded CA User Scripts and wrote a one liner to handle this: sudo find /mnt/user/downloads/ -mtime +7 -exec rm -rf {} \; Is there a better way to do this? Its preferable to remove the file in /mnt/user/downloads by the downloader. Does anyone know if rtorrent does this?
  7. Unraid newb here. Got my new server up and running. Plex is running great. Got my live tv up and running. I downloaded delugevpn tonight and followed spaceinvaders tutorial. The container works. I can download a public block list from the container. But, if I try to add a .torrent file to manually test it out, it shows the .torrent file name but it does not expand the torrent file and nothing is in "files" or "options" to add. These are from a private tracker. Any ideas?
  8. After I posted, It hit me that I didn't add "--device=/dev/dvb" to extra parameters in the plex container like I did in the TvHeadEnd. It picked up afterward fine. Thanks for the reply.
  9. I was wondering if I can get some help and hoping this is the right place to post. I am having trouble getting my plex docker container to recognize my tuner. I am new to unraid but not new to linux, docker, etc. I have unraid 6.7.2, I am using binhex's plex container, I have plex pass, I have Community Apps and have downloaded Unraid DVB. I have tried both LibreELEC and TBS CrazyCat 6.7.2. I am using This Tuner. Plex will not detect the tuner. Here is so more info from the community app unraid DVB: unRAID Version:6.7.2 Linux Kernel Version:4.19.56 DVB Version:LibreELEC Driver Version:1.3.1 DVB Kernel:Detected DVB Adapter Drivers:Detected DVB Adapter 0:LG Electronics LGDT3306A VSB/QAM Frontend DVB Adapter 1:LG Electronics LGDT3306A VSB/QAM Frontend Lastly, I stood up TvHeadEnd's docker and was able to find 40 or so tv channels through it. What am I missing?