DoleWhip

Members
  • Posts

    4
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

DoleWhip's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. TL;DR: 1. If Computer Configuration > Administrative Templates > Network > Lanman Workstation > Enable insecure guest logons shows "Enabled" but it isn't working, continue 2. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters 3. Double-click on AllowInsecureGuestAuth 4. Under "Value data:", change it from 0 to 1 Describing what I did troubleshooting-wise (not that it matters, but maybe it'll help someone): I updated my Windows 10 Education to version 2004 yesterday and was no longer able to access my SMB shares (was working fine before Windows update). I could see them, but double-clicking on my server name in Windows Explorer under Network gave me the generic can't access error. Luckily (because it helped me google my problem) I had pinned some folders in it, and trying to access those gave me the popup pictured in that preview/thread saying: "You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network." I was confused because my group policy under: Computer Configuration > Administrative Templates > Network > Lanman Workstation > Enable insecure guest logons showed "Enabled". Toggling this back and forth and restarting my PC didn't fix anything. My unRAID server SMB settings had enabled for workgroup, enable NetBIOS to yes, and enable WSD to yes. My workgroup under those SMB settings matched with my PC, I even retyped them in holding down shift to capitalize just in case. Local master was set to yes, and I also downloaded the Dynamix Local Master plugin to check for me and it verified that yes, my unRAID server was indeed the current local master. Still not working. I added: log level=2 syslog=3 to SMB Extras and saw in my syslog that my PC was trying to send my local user to access the SMB shares (which are set to public) with errors along the lines of: FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=1 and that I was trying to use SMBv2 In the end, I found the solution in the linked thread to do this: 1. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters 2. Double-click on AllowInsecureGuestAuth 3. Under "Value data:", change it from 0 to 1
  2. Regedit Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters Double-click AllowInsecureGuestAuth and change "Value data" from 0 to 1 This worked for me after updating Windows 10 Education to 2004, thank you!
  3. Gotcha, thanks for the confirmation, I appreciate it. Also thank you for maintaining this.
  4. How do I set this up to use an ephemeral port from my VPN service (Windscribe)? I requested a matching internal and external port from my VPN service, and within the qBittorrent WebUI I entered it into the field under "Connection > Listening Port" with "UPnP / NAT-PMP port forwarding from my router" off, no port forwarding options added to my router settings, and no added settings in the docker container edit page. If what I'm doing is already correct, do I also need to restart the docker container for the setting to be applied? I think my uploads are now faster, but I'm not sure how to test whether or not it's really working besides I guess just changing ports and eyeballing my upload speeds, but it's hard to fully accept it as not being coincidence. Hopefully I have this setup right and I'll just update that one field every time I get a new port (again, not sure if it requires a container restart), I was just mainly wondering if I have to add that port somehow in the docker container settings. I'm not much of a network person, so I apologize if I'm asking a very basic stupid question. EDIT: I ended up looking at the container log and noticed a line saying: "Successfully retrieved external IP address [blahblah]", so I input that IP address into a port checker with my ephemeral port from my VPN service that I set in the qBittorrent WebUI and it looks like it's open. Should I be adding any port settings to the container settings? I just left everything besides the setup for Windscribe VPN default and did not add anything else. Do I need to port forward anything to begin with on my router, like any of those default/ephemeral ports? In the log, I also see two different IPs from my new external IP with a line saying: "qBittorrent listening interface IP [blahblah] and VPN provider IP [blahblah] different, marking for reconfigure". Is that okay? My bad for all the questions.