(SOLVED) 6.9.0 Upgrade - User Shares Gone

Recommended Posts

I recently upgraded to 6.9.0, and I thought everything went fine.  Today I rebooted my windows system, and it said it couldn't reconnect to my user shares.  These are the ones that I had specifically set up for different user accounts.


All of the other regular shares for media and such are there.


I've tried rebooting, but no luck.


I can see that the disks are there with no errors.  I can also see that the files are still there. 


What would make the "user" shares disappear?

Edited by BAlGaInTl
Link to comment

The diagnostics are attached.


The shares used to be visible at //dmitri/user/


What was once the "user" share was segregated from my other shares and was on Disk 3/4 only.  Like I said... I can still see the data physically on the disk, but the share is gone. None of my applications or media touch those two drives.  All of that stuff is working as normal.


Any help/insight is appreciated.






Link to comment
9 hours ago, Squid said:


That share has no authorized users to read it.  Try setting up the user permissions again in the share (Toggle something off / on if necessary)


I guess that's the problem... there is no share listed for it. There's no place for me to set permissions.


I don't know where it could have gone.


 Maybe I'm missing something.

Link to comment
1 hour ago, Squid said:

What does that mean?


It just doesn't seem to exist in my shares.  I know it was set up, because I have //server/user mapped on multiple computers here in my house and they all stopped working.


This is what I see on my shares now:




Media is the main share where I have movies tv home videos etc.


The share "user" used to be there I think... It used two separate physical disks from the rest of the shares.  It worked for so long without issue, I don't even remember how I had it set up. :)


The two disks are still there... I can still browse the physical disks and see the files.  I just can't connect by SMB, and and all my network mappings broke.


Can a share named "user" just be recreated using Disk 3,4 and it will go back to working?


I'm just perplexed as to how it just disappeared in the first place.  There seems to be config files pointing to it in diagnostics, but it seems to be gone from any unraid menu.

Link to comment
3 hours ago, ElectricBadger said:

Is there a list of banned share names anywhere? I'd like to check mine are OK before I hit the update button 😁



Along with any of the following within the share name : \ / * < > | " ?   Or the same name as any of your cache pools

  • Thanks 1
Link to comment
  • BAlGaInTl changed the title to (SOLVED) 6.9.0 Upgrade - User Shares Gone
On 3/12/2021 at 8:53 PM, Squid said:

Reason is this (when I try and add a "user" share)




From the command prompt, you need to rename the share to some else:

cd /mnt/user
mv user my_users



So renaming the share worked and everything showed up.  I just had to give users permission to that share again.


It seems like the upgrade script should check to see if that's an issue before the upgrade. 


Either way, thank you for the help on getting this fixed.  I was racking my brain.



Link to comment

FCP is only checking for whats in /mnt/user, so you've got a share in there that's disallowed


	$reservedNames = ["parity","parity2","parity3","diskP","diskQ","diskR","disk","disks","flash","boot","user","user0","dev","disk0","disk1","disk2","disk3","disk4","disk5","disk6","disk7","disk8","disk9","disk10","disk11","disk12","disk13","disk14","disk15","disk16","disk17","disk18","disk19","disk20","disk21","disk22","disk23","disk24","disk25","disk26","disk27","disk28","disk29","disk30","disk31"];


  • Thanks 1
Link to comment

This issue is biting me now and the fixes above have not worked. After a reboot the share gets recreated every time. I'm completely locked out of SMB access again after it was sorta working before one of the reboots...


I never saw "disks" as a share in the gui, but I did see the folder in the root of one of my disk shares. I also saw a disks.cfg file in my flash drive somewhere, do i need to delete that (or NOT delete that)?

Edited by smashingtool
Link to comment
36 minutes ago, Squid said:

You have a docker container that is referencing /mnt/user/disks  You should be able to see that on the docker page and hitting the caret to expand any of the path mappings.

Hmm, I have several mappings to /mnt/disks, but i don't see anything to /mnt/user/disks...


Oof, yeah, you're kinda right but in a different way. I do the following mappings with my dupeguru containers:


/storage/disks <> /mnt/disks

/storage <> /mnt/user


I've always done that for the purpose of simpler file browsing in there, but that must be what is actually making the linkage


Anyway, you're my hero, ill clean this up and that should fix it...


Edit: Yep, all fixed. Thank you!

Edited by smashingtool
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.