Jump to content

Lock-up UNRAID with AMD GPU VM Passthrough

Recommended Posts

I'm a newbie. First post here!


I have just built my first computer in about 15 years and the process has been amazing. I didn't remember but it feels like legos for adults :). Also, the Unraid world is jut amazing and so many possibilities have opened with my new little cube server (I have the Fractal Designs Node 804)


Anyway. I have the latest version installed (still in trial mode) and most of it seems to running smoothly, but:


1) [SEEMS TO BE SOLVED NOW WITH UPDATED BIOS AND POWER SETTINGS as suggested by the FAQs] Mostly every night the server locks it self. The way I realize this is because my plex server looks unresponsive and my brother in Australia tries to connect to it while I am sleeping and it looks offline. So, then when I wake up I realize about this, I ping the machine and it works, but I try to go to the webUI and try to ssh and I don't get a response. This results in me having to do a hard shutdown, restart and then starting a parity check, then runs throughout the day and then finishes around 3am just fine with no errors. After this, the plex server backups the database around 5am, and by the time I wake up (around 6:30-7) the server is locked again. My brother usually tries to access just between these hours. I don't think this is related to Plex but it might.  


2) The other problem I am facing is the VM GPU Passthrough. In general, it works very well and I am able to play games through Parsec or Rainway. But some days I get an AMD error saying that the encoder can not be initialized. Moreover, almost every time that I shut down the VM, the server becomes unresponsive as well. In this case, I try to stop the array and do a proper reboot, but it stay stuck in that process and eventually I need to hard reboot my self. 


I've been reading the forum a lot and I have tried the FAQs and some responses in other posts but I haven't got to the root of the problem. Regarding the GPU, maybe the problem it is because is AMD? No clue regarding the server locking up, but maybe because of the Ryzen 1st gen problems (I have a Ryzen 7 1800x). I also getting some hardware cpu errors from the common errors plugin, but I've read I should worry about those. 


Attached are my current diagnostics, syslog, and plex logs. 


Please help!




AMD Ryzen 7 1800X 32GB DDR4

Asus B450m-a/csm

3x4TB nasred hdd

1x Black WD NVME 1tb



cookiemonsters-diagnostics-20210412-0957.zip syslog- Plex Media Server Logs_2021-04-12_10-29-13.zip

Edited by cookiemonsters
Link to comment
  • cookiemonsters changed the title to Lock-up UNRAID with AMD GPU VM Passthrough

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...