Permision denied to access share even with suffiecient permission on server


4 posts in this topic Last Reply

Recommended Posts

2 hours ago, Stev said:

It was a simple fix. Just restart your computer! Should've done that before posting smh. But if you encounter this in the future, you know what to do!

Not quite, I suspect you got bit by this 'gotcha' of SMB:


 

Quote

Let me give you an operational example.  Let's say your windows PC netbios name is "mypc" and your windows login name is "larry".  Further let's say your server netbios name is "tower" and you have a single user defined on unRaid side named "curly".  Now you open Network and click on "tower" and a window opens showing all the shares.

 

In this state, if you now click on a "public" share, what happens behind the scenes is windows tries to authenticate with the server as user "mypc\larry".  On unRaid side, samba (linux smb protocol module) will check if "larry" exists.  In this case no, so samba will check if user "mypc" exists, in this case also no.  So samba will now see that "guest" access is enabled for the server, so it will reply to Windows with "success" but on the samba side, will associate any further access with the "nobody" user on the linux side. 

 

 

Plus, SMB will only allow one login form any Client.  Hence, once you login with 'Guest' (user = "nobody") credentials to the Unraid server, you can't login a second time with the Unraid user name that has access to the Share. Rebooting your client will fix the problem because it breaks the client-server connection. 

 

Quote from this post:

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.