USB z-wave stick pass-through to domoticz docker gives kernel error

Recommended Posts

Hello all,


TLDR: I'm getting USB kernel errors when passing through a z-wave USB stick to a domoticz docker and I don't know what is causing it. 


I'm running Unraid 6.9.2 and I've been using a z-wave USB stick in combination with a Debian VM that has domoticz installed for a while now, which worked perfectly. However using a complete VM for just running domoticz is kind of overkill so I decided to move to the domoticz docker from Linuxserver. 


I've two devices passed to the docker and both are connected to a 2.0 USB port on the motherboard. 

  • P1 USB (in unraid known as /dev/ttyUSB0)
  • Z-wave USB stick (in unraid known as /dev/ttyACM0)


Settings used domoticz docker:

  • privilleges = true


Settings in Unraid GO file:

chmod 777 /dev/ttyUSB0
chmod 777 /dev/ttyACM0


The P1 converter is working after changing the chmod settings but the Z-wave usb keeps crashing.


The errors I get:



"Error: Zwave adapter: OpenZWave: Driver Failed!!"


kernel: cdc_acm 1-10:1.0: acm_port_activate - usb_submit_urb(ctrl irq) failed


Using the z-wave usb within the VM, made the VM responsible for the drivers etc. but now those have to be supplied by Unraid. The weird thing is, that I've seen the Z-wave usb work once in the Domoticz docker and I was able to switch a light.


At first I suspected that USB extender cable was causing the issues but connecting the z-wave usb directly to the motherboard didn't change a thing. So it doesn't looks like a driver issue because then it wouldn't have worked at all. 


All that remains is this weird kernel error that has never been reported by any other users on this forum.

If you have any ideas or things to check, please let me know!


Thanks! syslog-

Edited by kevi-n1
Link to comment
30 minutes ago, harm said:

Have the same in 6.9.2. I did a quick search and concluded it's the kernel used in 6.9.2. Reverted back to 6.9.1 and everything is ok. Now waiting for 6.10.0.

That was it! and it works now! 

I've been running 6.9.2 for a while now so did not thought about reverting back to 6.9.1...


Hope this gets fixed in the future.


For now thank you very much! :) 


Edited by kevi-n1
Link to comment
  • 4 months later...

I am on 6.10 RC2 getting the same failure: Error: Z-Stick Gen5: Driver Failed!!

Actually trying to use the domoticz docker from domoticz itself.

How do you pass through the usb device in extra parameters?

I am trying like this: --device=/dev/bus/usb/001/003:/dev/ttyACM0

But not sure if correct.


By the way .. the domoticz container from linixio is working out of the box with --device /dev/ttyACM0:/dev/ttyACM0.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.