Jump to content

[SOLVED] Files written to cache even though share set to "Cache = no"

Recommended Posts

I received a warning from Fix Common Problems that I have files on my cache drive for a share that's set to not use cache.


Here's the config for the "Sport" share:



Browsing the cache pool shows that recent files are there for the Sport share:


I copied the files from a temp directory (on Cache) to the Sport share using Krusader. Here's the path as reported by Krusader:


And here is the mapping for /media from the Krusader config:



Why is Krusader writing these files to the cache pool instead of waking up the drive (if necessary) and writing them directly to the array?





Edited by FreeMan
Link to comment

Did you try copying the files or moving them?     I am asking because you can get strange results using move where the file remains on the same drive but in the new directory (this is a by-product of the way Linux implements move and the fact that Linux does not understand User Shares).  You have to do a copy followed by a delete of the original to avoid this effect.

Link to comment
13 minutes ago, itimpi said:

Did you try copying the files or moving them?

I moved them as I've been doing for ages. I've gone back and forth between using cache and not, but don't recall having run into this before.


Based on your question, I copied them from the array to the cache-based temp directory, deleted them from the array, copied them back from cache to the array and deleted them from Cache. Now there are no file on cache.




10 minutes ago, trurl said:

#2 in this post I often refer to:

Thanks. I have been very much aware of the "don't cross the streams" admonition for years. Since I'm using Krusader and both directory windows work from "/media" I assumed (with all inherent danger, obviously) that it would work properly since it's always worked that way in the past.


I guess I know better now, and will be sure to "copy/delete" instead of "move" from here on out.

Edited by FreeMan
Link to comment
  • FreeMan changed the title to [SOLVED] Files written to cache even though share set to "Cache = no"

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...