Jump to content

trouble with new build [SOLVED]


Recommended Posts

I just assembled my new Unraid build which is as follows:

case: fractal node 304

mobo: MSI MPG B560I

CPU: Intel Core i5-10600K

Memory: https://www.amazon.com/gp/product/B08HLYSHJC/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1

PSU: https://www.newegg.com/super-flower-leadex-iii-sf-550f14hg-550w/p/1HU-024C-00008

CPU Cooler: Noctua NH-U14S, Premium CPU Cooler with NF-A15 140mm Fan


I just got everything put together and put in my 3 HDDs and my unraid USB drive.  When I tun on the system, it boots into the BIOS.  It seems to detect everything correctly - it shows the correct CPU and memory.  It see the hard drives and the USB stick.  I set the boot order to boot from the USB stick.  but after I reboot, it just keeps booting into the bios.


If I unplug the power cord from the PSU, wait a moment and then plug it back in and boot back up it usually spins up for a second and then shuts down - then spins back up and says "All settings were reset to default values"

Press F1 to Run SETUP

Press F2 to Continue

and all the bios setting I have made have been reset to default.


what the heck could be wrong?   I have not built a pc for several years so its possible I may have screwed something up :(


any advice would be greatly appreciated!

Edited by bdee1
Link to comment

Also, I think the really weird part for me

is that after I first connect the power and turn it on, everything spins up for a few seconds… but turn shuts down for a few seconds and powers back up with the cmos settings reset. 

and it only does this the first time after reconnecting power. 


Link to comment
14 hours ago, bdee1 said:

Thanks lolight. After removing the CPU cooler I was able to get a closer look and I see the battery. Is there a place where I can get an inexpensive replacement to try?

First try re-connecting the battery to the MOBO -  the connector might not be fully inserted.

You can get a cheap laptop CMOS replacement battery with a matching connector (2 or 3-pin) on ebay.

The connector is very small and tricky to disconnect. Make sure not to damage the socket it's attached to.


If that doesn't solve the problem I'm afraid you'd have to RMA your MOBO for a replacement.

Edited by Lolight
Link to comment

That was a good call!  Once I took everything back out and got a closer look, the connector for the cmos batter was actually loose.  I reseated it and reassembled everything and now it’s holding the bios settings!


now the next problem I am having is that I can’t seem to get it to boot from the flash drive. It sees it in the bios and I have set it as the primary boot device,  but it just keeps booting into the bios. 

I have found a few threads for other motherboards which said they had to switch from UEFI to CSM to get it to boot from the flash drive, but apparently CSM can’t be used without a discrete graphics card. 

I tried to switch it to CSM and when I reboot it displays an error message and reverts back to UEFI. 


Any ideas on how I can get it to boot from the flash drive?

Link to comment

Perfect - that did the trick - thank you!!


so now one other issue I noticed.   It booted right up and everything was normal, but when I rebooted, it would not boot back into unraid.   It got through the POST, and then just went to a black screen.  The web up was not available and my router did not show the device as online.


I powered down, removed the flash drive, re-inserted it and then powered back up and then unraid booted.


This seems to be happening every time I reboot.


any ideas?


Link to comment

Thanks trurl - I had the same thought and I have actually tried every available port with the same result, including the two USB2 ports.   It didn't seem to change anything.


One thing i did notice though is that after a reboot, if I unplug the usb drive and plug it back into the same port - it still hangs after I boot back up. It will only boot if I plug it back into a different port.



Link to comment
  • bdee1 changed the title to trouble with new build [SOLVED]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...