Jump to content

No signal to HDMI with pass-thru GPU after upgrading to 6.9.2


Recommended Posts

I have seen a few other posts about this, but nothing that was said there has fixed this for me. I have a GPU that I need to pass-thru to a VM. The device shows up in the PCI list (under Linux)/Device Manager (under Windows), but I get no signal out the HDMI port.


Things I have already checked/tried:
0) I have confirmed the GPU, monitor, and HDMI cable all work when swapped to bare-metal devices, and this setup was working fine until I upgraded to 6.9.2.

1) I have tried switching OSes from Linux to Windows

2) I have tried switching "Machine" type; I have tried every version of both machine types under both OSes

3) I have confirmed that the GPU and its associated sound device are part of an otherwise-isolated IOMMU group and have tried both with and without having that IOMMU group being assigned to VFIO at boot.

4) I have tried both SeaBIOS and OVMF

5) I have tried using SpaceInvaderOne's vbios dump script, it always generates an error, even with Docker and VMs disabled. (See https://pastebin.com/ejFpvmPi for output); I have done as suggested in the video and rebooted the machine with the GPU bound to VFIO at boot, to no avail.

 

 

Any ideas or suggestions would be appreciated; Without this HDMI port working, we are unable to monitor our surveillance camers in realtime.

 


 

Loading config from /boot/config/vfio-pci.cfg
BIND=0000:02:00.0|10de:1d01 0000:02:00.1|10de:0fb8
---
Processing 0000:02:00.0 10de:1d01
Vendor:Device 10de:1d01 found at 0000:02:00.0

IOMMU group members (sans bridges):
/sys/bus/pci/devices/0000:02:00.0/iommu_group/devices/0000:02:00.0
/sys/bus/pci/devices/0000:02:00.0/iommu_group/devices/0000:02:00.1

Binding...
Successfully bound the device 10de:1d01 at 0000:02:00.0 to vfio-pci
---
Processing 0000:02:00.1 10de:0fb8
Vendor:Device 10de:0fb8 found at 0000:02:00.1

IOMMU group members (sans bridges):
/sys/bus/pci/devices/0000:02:00.1/iommu_group/devices/0000:02:00.0
/sys/bus/pci/devices/0000:02:00.1/iommu_group/devices/0000:02:00.1

Binding...
0000:02:00.0 already bound to vfio-pci
0000:02:00.1 already bound to vfio-pci
Successfully bound the device 10de:0fb8 at 0000:02:00.1 to vfio-pci
---
vfio-pci binding complete

Devices listed in /sys/bus/pci/drivers/vfio-pci:
lrwxrwxrwx 1 root root 0 Sep 5 17:22 0000:02:00.0 -> ../../../../devices/pci0000:00/0000:00:02.0/0000:02:00.0
lrwxrwxrwx 1 root root 0 Sep 5 17:22 0000:02:00.1 -> ../../../../devices/pci0000:00/0000:00:02.0/0000:02:00.1

ls -l /dev/vfio/
total 0
crw------- 1 root root 249, 0 Sep 5 17:22 33
crw-rw-rw- 1 root root 10, 196 Sep 5 17:22 vfio

 

Link to comment
6 hours ago, technorati said:

5) I have tried using SpaceInvaderOne's vbios dump script

 

So, you are running it with a vbios or not?

Sometimes missing output to video ports depends on wrong vbios.

I would say it's mandatory to use a vbios dumped from your gpu, so if you're running your vm with a vbios, you need to find a way to dump it from your gpu.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...