Jump to content

Container docker hub and volume mapping to appdata


Recommended Posts

Hello,


Sorry, maybe the answer has already been said but I have an issue with a specific docker container from docker hub and I lack knowledge about that.

i'm trying to install the docker container mediawiki from docker hub : https://hub.docker.com/_/mediawiki


- No volume mapping : the container works flawlessly, pretty logic.
But I want to save the data from the container path located in the folder /var/www/html/

- When I try to set a path mapping in a new container, aka :

/mnt/user/appdata/mediawiki (host) > /var/www/html/ (container)

 


appdata/mediawiki folder is empty and the container displays an error message

"Forbidden

You don't have permission to access this resource."


CLI obtained when the container is created :


root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='mediawiki' --net='redwaxnetwork' -e TZ="Europe/Paris" -e HOST_OS="Unraid" -e 'PUID'='99' -e 'PGID'='100' -p '9090:80/tcp' -v '/mnt/user/appdata/mediawiki':'/var/www/html':'rw' 'mediawiki'

8c49790229ca2bb22a0ae1606582dc7254a1c26b017852838057a25871c5371f

 

Link to comment
  • 1 year later...
  • 6 months later...

Just chiming in here because I also get this issue (different container) and have done a few times.  I don't understand why it's happening.  Sometimes parts of the directory come through, like just the folder name but without the files.  Another time one directory will come through completely but not the other.

 

The main difference I note is I'm using the extra dockerhub link rather than Unraid App Store default in this case for idrive backup container here: https://hub.docker.com/r/taverty/idrive/

 

I'd bet if I set this up manually in docker on ubuntu or something it'd work.  I think there some fancy unraid stuff meant to make it easier getting in the way or something, I don't think it's me but could be wrong!

 

The first time I ran this container, I had an empty scripts directory and no /etc directory.  I deleted it and tried again, this time I have no scripts directory and a full /etc directory.

 

I've triple checked my paths are right, it makes no sense.

 

And to make matters worse the data is lost both inside and outside the container. i.e in this case there is nothing under /opt/idrive/IDriveForLinux/scripts/ or the hosts equivalent mountpoint.  If I remove the line it all comes back with a container restart.  Seems like some kind of weird bug.

 

I've removed the docker file a few times including deleting the whole image and the host docker directory simultaneously, still the same.  If anyone knows any tricks around this, that would be appreciated!

 

Thanks,

 

Marshalleq.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...