Random loss of DNS


Recommended Posts

2 hours ago, Osiris said:

So, when this issue occurs, you can perfectly ping google.com from the host, but the docker containers lose access to the web?
When this occurs, could you do 

docker exec -it containername /bin/bash -c 'cat /etc/resolv.conf'

for your failing containers.

 

edit: nevermind. Saw your router issue.
You're not running an openwrt with your own dhcpd & bind/named?

No, when this issue occurs everything loses DNS resolution. Webui, Dockers, SSH, everything. I haven't tried spinning up a VM yet but that's next on my list.

 

The router is a Zyxel USG110 (not my choice but it's not my network). I'm talking to the business owner about putting in my own router in front of my gear. No openWRT. UnRAID doesn't pull DHCP, all of it's network settings are statically configured and DNS is set to go straight to cloudflare and google for lookups.

Link to comment
  • 1 month later...

All of this seems to have been resolved by putting my own router in. Plugin & docker update checks are 3-4x faster than before. pings to hostname's start faster. I'll keep monitoring for DNS issues but I'm considering this resolved for now.

 

A $100 J4125 box from aliexpress and pfSense CE made a night and day difference over that zyxel.

Edited by weirdcrap
  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.