Jump to content

webgui not starting 6.11.5


Recommended Posts

This is probably something I'm just not seeing...

 

BLUF: the webui isn't running on my server.  I can't even get to it from the local tower when I try to log in using GUI mode.  


I recently was trying to upgrade my license from basic so I could have more drives attached.  In doing so, I found the  "My Servers" piece and enabled it.  This allowed me to upgrade and have the license pushed to my USB device.  That part worked.  But then I started having problems with the webui.  First, I had done something to get an unraid cert and that turned on SSL for the web ui.  I was able to log in at the console and reboot then start it in GUI mode.  From there I was able to see that it was looking for an SSL connection and it gave me the option to turn that off (seemingly).  After a couple of reboots things were working fine again, for a bit...

I've been scouring the web trying to find how to manually start the webui and I found a thread on here about someone else's struggle and things that worked for them (

 

I tried to perform the command /etc/rc.d/rc.nginx restart but my results were "Nginx is not running".  So I tried Nginx start which told me  'invalid number of options in "server_name" directive in /etc/nginx/conf.d/server.conf:65".

So I took a look at the file but I find there is nothing in the server_name.  It is just a [tab] followed by a semicolon? 

What should I edit this line to be?  Is that my only problem?  How did it get messed up to begin with?

Thanks for any help,
 

server_name_issue.jpg

server_name_empty.jpg

tower-diagnostics-20221213-1247.zip

Link to comment

Yeah the issue is that eth0 doesn't have an ip address and that is needed in order to use a myunraid.net cert. If you don't want to swap the cables around...

 

At the console, type:

rm /boot/config/ssl/certs/certificate_bundle.pem
use_ssl no

Or if ssl is already disabled, do:

rm /boot/config/ssl/certs/certificate_bundle.pem
/etc/rc.d/rc.nginx reload

 

Hopefully that should get the webgui to load again.

 

Then go to Settings -> Network Settings -> Interface rules and reassign things so that the nic that has an ip address is recognized as eth0. Once you have an ip on eth0 you should be able to provision a cert.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...