Jump to content
Sign in to follow this  
Alex.vision

[SOLVED] New MSI 870-G45 build with network errors

4 posts in this topic Last Reply

Recommended Posts

Hi everyone.

 

So this is my second post to unraid, and my first question on the boards.  I have been really into unraid for about six months now and enjoy it.  I have been very surprised with the amount of help that I have read on the forums, being a Linux noob I have found the forums very helpful.  I decided a while ago that until the problem was severe I wasn't going to bother the forum members with questions I could just as easily Google myself.  I recently switched my first unraid build from an old Intel Dual Xeon Dual core to a newer MSI 870-G45 with 4GB of ram and a AMD Phenom II x 4 955 BE.  2x AOC SAS cards (only 1 installed), 6x WD EARS 2TB and a mix of 5 1TB HDD.  I know the proc is overkill but I want the power for all of those nice unMenu addons.  So here is my problem.

 

I had everything hooked up and was doing a parity check (sever has been off for about 25 days) and everything went fine, no errors.  I went to pull a file off from the user share and the network seemed to fail.  On my win 7 machine the loading circle would run, like it was waiting for the drive to spin up.  The unraid config page and unMenu both work fine, but I cant transfer anything to or from the server.  Of course this led me to think my nic was bad or incompatible (Atheros AR8131M).  So I pulled my old unraid server apart and pulled out my gigabit nic from that and plugged it in. Now comes the problem.  I have since read that my Atheros card is indeed incompatible with unraid which is fine I have the extra card, but when I disable my on board nic my motherboard responds with error 418C.  The board refuses to boot with the on board nic disabled.  I have updated the bios to the newest ver. 10.8 and still nothing.  What I would like to know is, is it possible for me to leave my other nic enabled, but not plugged in, and use my card for my network.  Also my internet situation is a bit wonky, so let me say I need unraid to have a static IP.

 

I know almost nothing about Linux and so Im not sure if there is a way to tell it to use the second card with a static IP.  I know the ifconfig command to view my nic config, and I know eht0 command as well but other then that I come up Linux empty.

 

-Alex

 

PS using unraid 4.7

syslog-2011-07-10_1.txt

Share this post


Link to post

Just a thought, but did you make sure the LAN Boot ROM option was disabled before you disabled the onboard LAN?

 

Something like...

Enable onboard LAN, save & reboot

Make sure the LAN Boot ROM/PXE option is disabled.

Check the BIOS boot order to make sure LAN/PXE isn't specified.

Disable onboard LAN, save & reboot.

Share this post


Link to post

...in case you cannot switch off your on-.board NIC, it should be fine to run unRAID with a dual-NIC setup.

Just don't generate traffic on the on-board one (don't use the IP with your clients to connect).

You'll have to configure the second NIC manually, I am afraid.

This link might help: [sOLVED] Configure second NIC

 

...a custom udev rule could also change the sequence the NICs are named, I think.

This way your on-board NIC could end up as eth1 and your add-on NIC would be named eth0

But this is quite an advanced task to do.

Share this post


Link to post

By adding ifconfig eth1 x.x.x.x netmask y.y.y.y up to my go script this solved everything.  Thank you so much for the help :)

 

-Alex

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this