Jump to content

Failed motherboard, rebuilt machine, now all disks are missing, use New Config?


Go to solution Solved by rockrimmon,

Recommended Posts

Hello,

 

I had my Unraid server running with all disks (7 hard drives and 6 SSDs) configured and running. All drives were connected via two PCIe HBAs. The old server was a SuperMicro motherboard and Xeon processor. The motherboard failed suddenly with no errors prior to failure. Applying power resulted in no power on self test running at all,. fans started, but nothing else worked. After verifying the power supply was good I started looking for replacement parts. The SuperMicro was not available on Ebay at the time, and I had found that the Xeon CPU was running pretty much maxed out at all times.

 

I ended up with a new ASRock Rack X470D4U2-2T motherboard with an AMD Ryzen 9 5900X 12-core, 24-Thread processor. I rebuilt the internals with the new motherboard and AMD processor, I re-used the HBAs and all cabling from the HBAs to the drives is the same. 

 

Upon booting the new setup Unraid starts up with no problems for the OS. However, every drive (parity, data, cache) is coming up as No Device on the Main tab of the Unraid UI. I know New Config can be used for some array issues. But before I used that big hammer I wanted to check if that was the appropriate approach in this scenario or if anyone had any other thoughts to try?

 

Thanks, 

Edited by rockrimmon
spelling correction
Link to comment

Post up your diagnostics file. 

 

Then make sure that the array is stopped.  Then look to see what drives are available to be assigned...

 

Are the drives even being detected? 

 

Are the number of drives detected equal to the number of drives installed?

 

Do you have a printout of the old drive assignments?  (If you have notifications setup, be sure you look at the sent messages on your notification option(s).)

Edited by Frank1940
Link to comment

Attached is the diagnostic zip file.

 

In looking deeper into the details, it looks like no media (HDD nor SSD) is being detected at all. The PCIe slots on the new motherboard are numbered different than the old SuperMIcro, not sure if that is causing any issues.

 

No disks are showing as unassigned, nor as available, and no disks are found in the array view.

 

I am wondering if my HBAs are working, I will try stripping out everything but one HBA and then try attaching drives to the one HBA and see if anything changes. 

lv426-diagnostics-20221222-2012.zip

Link to comment

Sorry for the typos. I reused the HBAs as well as the breakout cables from the HBAs to the drives.

 

I replaced the power supply and used the new power supply cables, none of the old power supply cables were used. 

 

As noted in my prior response, it looks like the PCIe HBAs may not be working. I will investigate that further tomorrow. 

Link to comment
  • Solution

Problem resolved. The ASRock Rack X470 motherboard requires manually forcing a split between two of the PCIe slots when using two x8 PCIe devices under specific conditions that my setup required. I updated the setting in the BIOS and both HBAs are now seen and all data and cache drives are found and array started error free. 

 

I may replace the two 8 channel SAS/SATA HBAs with a single 16 channel device to make things a bit cleaner. 

 

Thanks for the assistance. 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...