Docker Containers Shutting Off, Error 403. Corrupted or Full Cache Drive.

Recommended Posts



I am having this issue with docker.


It started a couple months ago where my docker containers would all shut off and every time i tried to restart them i would get error 403. After a server restart, it would be fine for a random amount of days (Longest is 19 days, shortest is 3 days) and the issue would pop up.


Something I noticed is that the docker img file itself would be gone from the docker folder. This time though its still there which is confusing.


Recently, Fix Common Problems has been notifying me that the cache drive is either full or readonly and my docker img is either full or corrupted.


Checking the logs, I was getting btrfs errors so I assumed that the btrfs file system was corrupted so I ran the check file system for the cache but it did not give any errors (I had to run this after restarting the server because it would not let me stop the array, it said stopping but never did so).


Same problem showed up after a couple of days so I believe my btrfs file system is corrupted.


Should I reformat my cache drive and instead use xfs for the cache drive or is there something else wrong that I haven't found?

Link to comment
Jan  2 23:16:02 Tower kernel: ata5: COMRESET failed (errno=-16)
Jan  2 23:16:02 Tower kernel: ata5: limiting SATA link speed to 3.0 Gbps
Jan  2 23:16:02 Tower kernel: ata5: hard resetting link
Jan  2 23:16:07 Tower kernel: ata5: COMRESET failed (errno=-16)
Jan  2 23:16:07 Tower kernel: ata5: reset failed, giving up
Jan  2 23:16:07 Tower kernel: ata5.00: disabled
Jan  2 23:16:07 Tower kernel: ata5: EH complete


Cache SSD dropped offline, check/replace cables.

Link to comment
  • 2 weeks later...
  • 2 months later...

Replaced Cables about 3 days ago when ssd dropped out again. Before that it did not drop out for a month.


It just dropped so I am guessing either bad ssd, sata port on mobo, or could be power supply. Ill try switching the sata port to see if it fixes it. 


Also, dont think this is related but for the month it worked fine, I had my Pi-Hole docker off. I turned it on about a week ago then ssd dropped 3 days ago. Gonna try turning it off to see if that helps.


Got new logs uploaded.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.