Cache. Unmountable or no file system

Recommended Posts

My cache SSD says it is Unmountable: Wrong or no file system.  The shares are also gone and not accessible.  This occurred after I had to reset the web GUI root password by deleting a couple files (smbpasswd and shadow).  I have tried to re-seat and swap the SATA cable, but this has not corrected the issue.  The Check Filesystem Status came back with Csum mismatches, bad tree block, owner ref check failed, bytenr mismatch, and unresolved ref dir.  I also tried recreating the missing share, but this has not restored the files.  Attached is the diagnostic report.  Can anyone offer advice on how to get my files back and system running again?


I am a novice with with Unraid, so even basic issues may be at fault here.  Thanks for your help!

Link to comment

I did replace the sata cable on the cache drive.  I made sure all the other cables were seated well. Should I try swapping more of the sata cables?


I forgot to mention in the original post that I have been having issues with the system shutting down on its own after about a week of up time.  When it does this, I have to switch off the power supply for about thirty seconds and then the system will power back on.  I have already replaced the power supply.


Again, thank you for your help!

Link to comment

I tried swapping both the power cable and the socket it is plugged into on the PSU.  I swapped some more SATA cables.  The cache still shows Unmountable: Wrong or no file system.  My Disk 1 that was disabled now shows not installed, but available as an unassigned device.  What should my next steps be?



Link to comment
6 hours ago, JorgeB said:

still ATA errors

there are


You need to fix those before any next steps.


Check connections, SATA and power, both ends, including splitters. Don't bundle data cables. Make sure all cables have enough slack so the connector can sit squarely on the connection with no tension. Only 4 disks per power cable.

Link to comment

I have tried new SATA and power cables.  I have swapped drive positions.  It seemed like the ATA errors were following the cache drive.  An IT friend took a look at the cache drive and said it may be corrupted, but looked functional.  We did not attempt to format it yet since I am not sure what data exists on it.  He had a spare 850 Evo SSD.  I installed that in place of the original cache drive.  I have attached the diagnostics with this configuration.  It seems like the ATA errors are gone, but now I see ACPI errors.  Can you help me determine the next steps?  Thanks!

Link to comment

Well the array is not started now since drive 2 is disabled now along with drive 1.  I think this happened when the computer was booted with a loose sata cable on drive 2.  Drive 2 has a warning stating udma crc error count is 16.  I don't know why drive 1 is disabled, but has been since the start of the issue.  Is it safe to add drive 1 and 2 back to the array at this point?  I don't want to loose the data on the array.

Link to comment
9 hours ago, odachiman said:

Is it safe to add drive 1 and 2 back to the array at this point?  I don't want to loose the data on the array.

Since you have dual parity you can start the array with 2 missing disks. If either of the disks are currently not assigned, don't reassign them. Just start the array and post new diagnostics.


Link to comment

All the array and parity disks are present and connected in the machine.  Drive 1 is the unassigned device ending in 70MW.  The SSD connected now is not the original cache SSD.  I have put in a new SSD where the unmountable drive was to test if that cleared things up.  I am still not sure if the drive is the issue or the motherboard or some setting in the bios.  Thanks!

Link to comment

The drives are mostly empty at this point. So the low file size is expected.  What would you recommend as the next step?  Should I attempt to get a new SSD to replace original cache drive or do I still need to sort the ACPI errors?  Thanks!

Link to comment

My BIOS is up to date, but I did a reflash anyways.  Still showing the ACPI errors. 


Should I try to pull data off the disks with a recovery tool before rebuilding?  Though there is not much data on the disks, I cannot loose what is on them.  Currently the share that had all my data is not present.  Will rebuilding the disks delete my data since the share is not there and not populating the files?

Edited by odachiman
Link to comment

Rebuild won't delete any files because parity doesn't know anything at all about files.


A missing/disabled/failed disk is emulated from the parity calculation by reading all other disks.


Rebuild will simply write that emulated data to the disk. Whatever you have now on the emulated disk is what you will get by rebuilding it.


5 hours ago, odachiman said:

The drives are mostly empty at this point.


Maybe the missing data was on cache. Cache is not part of the parity array and can't be rebuilt from parity.


Cache is not currently assigned, but earlier you said it was unmountable. If your missing data was on cache, you would have to recover data from that cache drive if you could get it to work.




Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.