Cache drive - Unmountable: Wrong or no file system

Go to solution Solved by JorgeB,

Recommended Posts

Hello everyone,


I have one 2TB nvme drive that is running all my cache (appdata, domains and system) and also have my daily driver Win10 VM (with gfx passthrough) on that nvme.

Just recently the VM went a bit haywire so I rebooted it. That didn't have any effect, so I rebooted the server.

After that, the nvme drive on the Main screen is showing 'Unmountable - Wrong or no file system'.

I have rebooted and tried reseating the drive, but no improvement. It gives me the option to Format the unmountable disks, but I don't want to go ahead with that until I have found out any possible issue (I do have backups of the three shares mentioned above and the VM). I did also stop the array, removing it as a cache drive and try mounting the drive as an unassigned device, but didn't like that either.


Thanks in advance!

Link to comment
  • 2 weeks later...

Just an update. The 'Wrong or no file system' issue came back every time I shut down my Win10 VM. Time for a cache reformat!

I decided to Move everything off the cache using the Cache:Yes and initiate Mover to get it on to the array. Some stuff got a bit stuck but I used Dynamix File Manager to shift it across on to the array manually. I changed the file system to xfs on the cache drive, formatted it, then changed back to btrfs and reformatted. I set the Shares I had on the cache back to Prefer and moved everything back on to the cache. Whilst it seems like that should just work, I had all sorts of issues with my docker containers and VMs that didn't appear in the tabs as they couldn't read the appdata properly. I had to restore my original appdata from backup, then go in to Apps and Previous Apps to download my containers again from the saved templates and set to read from the restored appdata. Once I did that, the dockers came back with their previous settings. Also after that, the VMs appeared and were able to boot with no issues. Another issue that I had with the docker container was that the Plex database was corrupt. I tried SpaceInvaderOne's solution on his very helpful YouTube video, but that didn't work either. I did have 2 or 3 database backups in the same folder and replaced the database with the last backup. That's now working. 

A bit of a learning curve for me, but I hope that I have everything fixed now and a more stable cache drive!

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.