Jump to content
We're Hiring! Full Stack Developer ×

AOC-SASLP-MV8 and ASUS M4A78LT-M AM3 compatibility issues?


GoZags

Recommended Posts

I am having devil of a time with this whole unRaid setup and would appreciate some guidance.  The primary problem, so save some re-writing, is here:

http://lime-technology.com/forum/index.php?topic=13822.0

 

In short, the performance of the drives on the MV8 card is suspect.  Preclear was chugging along at less then 25mb/s when I finally killed it.  Took the SuperMicro card out and moved the drives to the onboard SATA ports (of which there are 6 on this board).  Started preclear (for the 40th time it seems...  :-\ ) and they are going at 110 mb/s and 102 mb/s currently.

 

I went into the 'BIOS' of the SuperMicro card - there are very few things to change.  The PC as a whole boots up without error with or w/o the card in there. I had a drive in the first 8 bays as a test and unRaid actually sees the devices in each bay and lets you assign them, etc. 

 

Anyone have ANY suggestions?  Some BIOS changes perhaps?  Funnily enough, in the board BIOS I don't see any SATA mode changes, etc. No references to AHCI on/off, etc.

Link to comment

So the slow preclear with motherboard slots are all fixed?

 

There will be setting for AHCI some where, perhaps to do with the SATA controller. you'll see options for RAID and IDE.

 

Is the motherboard running the latest BIOS?

 

What BIOS is on the supermicro card? .15 or .21?

 

Which slot is the supermicro card in?

 

Thanks Josh

Link to comment

Thanks for the reply.

 

I think the slow/error pre-clear with the onboards are fine.  I re-secured the SATA cables, made sure there is no tension on them, etc.  Reseated the power supply connectors (on my cages there are two old-style connectors on each one that feed the 0-4 drives [5] in the cage).  I RMA'd the one drive and got the new one back.  I am currently pre-clearing two more drives on the onboard SATA and they will finish within 24-30 hours at the pace they are going. These are the WD EARS drive. At that point I think I have all the drives cleared so regardless of the AOC situation I might start finally creating the array and getting some data on this thing.

 

I don't know what BIOS version is on the board or on the AOC.  After the pre-clear finishes I will double check. They were shipped to me this past winter and I hadn't changed them, I know that much.  I will assume it is safe to upgrade the ASUS BIOS.  Any reason I wouldn't want to upgrade the SuperMicro card?  I will poke around the BIOS and confirm the AHCI settings.  The AOC BIOS itself though had barely any settings - would the card be pulling some settings from the mainboard BIOS in some way?  Maybe settings for the PCI-e slot it is in, per the ASUS BIOS?

 

The SuperMicro is in the PCI Express 2.0 x 16 slot.  I have a small 2-port SATA card (forgot which brand) in the PCI Express x1 slot and I pre-cleared an 80gig 10k Raptor drive in that just to check and it finished in a blink of an eye with no errors. In my setup I have one SATA cable coming off that (leaving one empty), going to the last bay in the last cage.  I am assuming that is all fine.

 

Thanks!

Link to comment

I'd reseat everything and check the BIOS first otherwise I'm not 100% sure sorry.

 

I'd try and unplug everything, and just preclear one hdd on each port, motherboard, Supermicro and the other PCI card you have. That way you can eliminate a few things.

 

I had a few issues when trying to preclear on the supermicro card when I had other drives being accessed for media. The preclear would seem to cause the media to freeze so It may have to do with multiple drives running at the same time.

 

The supermicro BIOS shouldn't make too big a difference as it will run on both .15 and .21 although you can get problems with it not booting on .21 with some motherboards. (I don't think yours is one of them)

 

josh

Link to comment

I posted this on the general forum (sort of have this going in two places).

 

Update:

 

Cleared 4 new WD 2TB EARS drives with the onboard SATA.  Two individually, two at the same time.  Average speed was 100Mb/s even with the two going at once.  Final run time was in the 28 hour range for the two at a time and 26 hours for the two going by themselves. No errors on either drives and I would say they work fine.

 

BIOS on the ASUS board is 802 (or 8.02, however they designate it) which is the latest according to ASUS - late 2010, when I bought the board, actually.

 

SuperMicro card is .21, which is the newest BIOS for that.  I reseated it and reattached the cables.  I have a ton of 80gig 7200 rpm drives and 5 or 6 340gig drives as well.  I think I will get this thing setup on the built in SATA ports, make my shares, etc and start using it.  I can experiment with the SuperMicro card and the smaller drives at that point and see if I can replicate the issues.  Unfortunately I think the two sets of 1 to 4 SATA cables were $20 each (anyone know some 'good' ones, high quality?).  I am weary of ordering more just to test but I may have to.  I have a 2-port card for the final SATA drive (#15) and that one clears fine. So even if the AOC, for some reason, can't preclear but reads/writes fine I may just use #15 to clear drives as I get them (a ways off from that, I can run 4 2TB and two 340gb drives on the on-boards for awhile).

 

AHCI was setup correctly for the on-board. Does anyone familiar with the SuperMicro card know if you need to adjust that BIOS in any way???

Link to comment

I have a rather similar setup on my server (ASUS M4A78LT-M LE MB with the Supermicro AOC-SASLP-MV8 Controller Card but with Supermicro FW Breakout cables.

 

My MB is cheaper version than yours (crappier onboard NIC on mine) but otherwise specs look quite similar. Main difference in my setup seems to be that I am using the Supermicro FW breakout cables. They were not the cheapest, but have worked perfectly. I never touched the AOC card settings in any way, or changed BIOS on it. The controller card came with BIOS 21 on it, and I didn't change anything. It was a plug and play install.

 

I have seen slightly faster speeds off the onboard Sata ports, as expected, but preclears and parity checks since intial build have worked very well via the SASLP-MV8 card.

 

I'd suggest you get a set of good SFF-8087 cables, reseat the controller card in the PCIe slot where the graphics card usually goes (top light blue slot on my MB), and troubleshoot from there on.

 

Good luck!

 

Link to comment

It's unlikely any settings on the Supermicro card will have an effect beyond the staggered spin-ups.

 

Might have missed it but I don't see a syslog here or in the other thread. Can you post something that includes one of the preclear runs? I'm thinking you might have something happening between the card and MB that's causing the slow performance.

 

Being lazy vs reading history, I have to suggest things like trying another PCIe slot, checking BIOS settings for slot speed, lanes, etc.

Link to comment

Thanks Prof. I will poke around and see if I can find those cables at a decent price.  It may come to just replacing those...

 

Thanks guys,

s

 

No worries. I hope it's as simple as that!

 

About finding a good price, poking around is definitely the best option. Check the Good Deals area on this forum, seen there a few very good deals. Don't know where you're at, but location will be key.

 

I'm in Australia, buying a good set of cables down here at a decent price was next to impossible. I bought my server's Supermicro bits from an eBay business seller from San Jose (bakamuzko). Although I had a very good experience with them, and they answered all my questions promptly--as with all online purchases, all I can say is buyer beware.

 

Good hunting!

 

Ramon

Link to comment

I haven't pre-cleared any drives yet, but it does seem to read and write ok from the AOC card. 

 

Strangely, the key seems to be the INT13 setting on the card. I disabled that and the r/w seems to be better.  The suggestion came from the feedback on NewEgg and specifically mentions unraid and disabling INT13...

 

http://www.newegg.com/Product/Product.aspx?Item=N82E16816101358

 

I also added a 10/100/1000 Intel Pro PCIe NIC and a 4 core AMD Phenom (?) proc a friend gave me (only two running at the moment, the heatsink is for a one core and it gets a little to warm with 4 cores going).  Putting a 10k rpm drive as a cache drive I could WRITE at 100mb+ from a 7200 rpm HDD over Gig ethernet.  Direct copying to the 5400 rpm green drives would hover between 20-30mb.  Read was 40+ easily enough off the green drives once the data was all the way written.

 

Yet ANOTHER WD EARS drive died on me, that makes both drives from the same order as failures in under a year with really no use (precleared, thats it).  Probably switch to Hitatchi or something else as get new drives.  what makes me most angry is that WD makes you pay for shipping to them for RMA's.  I got pretty irate with the CSR, it makes no sense.  I spend X number of $'s on a product, it is warrantied for X number of years.  It fails, but I have to spend money (increasing the original cost) to get it fixed??

Link to comment

Glad to hear you're starting to get good results from your troubleshooting.

After I replaced my onboard NIC with an Intel Pro, quite similar to what you're using now, I had to optimize network settings so everything would work at Gigabit speeds. That helped a lot with the transfers, as did using Teracopy to copy large files across the network.

 

Totally agree about WD and their RMA process. It's more than a pain. Most of my drive failures (two out of three) were also WD drives. After considering high cost of RMA process (ship the drives to another country in my case) I had to opt on just binning the WD drives still under warranty, and bought other brands. I had been using Hitachi on my NAS and HTPC without issues.

 

I did not see any positive effects from my tests with a cache drive. Glad to hear your experience is better with it.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...