Error "Cannot create or write into the data directory"

Recommended Posts

Error "Cannot create or write into the data directory" 


I can not get around this error, it does not matter if I try and install NextCloud, or any other App that requires a database to be created.


Be it MariaDB or Postgresql. 


I have changed directories, owners, permissions and everything I can think of. 


I have installed UnRAID Version 6.11.5 2022-11-20. 


I even went so far as to run "New Config" and still the same problem


I like the UnRAID interface, and if possible not go back to TrueNAS.


Any help would be appreciated. 

Edited by LyndochAVs
Link to comment

When I go to the WebUI for the first time after installing an app. 


The app askes to create an administrator account and you configure the Database for the first time,


I get the error Cannot create or write into the data directory


I have tried different directories, giving full permissions to the 'user' of that directory and still luck.


I've printed off the entire UnRAID user manual that is available online and I must admit it is very brief and obviously assume a mass of prior knowledge that I just don't have right now. 



Link to comment
  • 2 weeks later...

Are you specifying "LOCALHOST" or the IP address of the server?


LOCALHOST within a container does not mean the server's IP.  It refers to the IP of the container itself.  You would need to specify the IP address of the server and the port you've specified for the database


FWIW, I just installed Nextcloud and MariaDB (both from LSIO) with no apparent ill effects and no logged message like what you're seeing....

Link to comment

I installed Docker elsewhere, and I am getting the same problem even when using the database ip and not the server ip. 


Thank you for your help, but I think I will go use another platform that I know works for me, and forget about Unraid.

Link to comment
  • 3 months later...
  • 1 month later...

Hope this can help anyone else with the same problem...


When you create the docker you set the location of your files in "User Files"


Note that the container is going to access this path through /var/www/html/data .

When you are setupping the account you are now asked where to add the Data folder:


If you change this path you will not point to the data folder you defined earlier, this will cause the interface to issue the message you are seeing.


PS: Other problems may cause the same, but I dare to say this is a common mistake.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.