Jump to content

Slow zero-clear disk script with Turbo-write


Go to solution Solved by JonathanM,

Recommended Posts

I followed the Shrink array instructions with the user script for clearing an array disk.  As soon as I started the script, the write activity to the clearing disk was ~600 KB/s, and web UI interactivity went to shit.  Plex stopped responding, I had to log in via SSH to shut plex and several other docker containers before I could get back in via the the web interface.

 

In 'top', the "Wait for I/O" was sitting around 70-90%.

 

I tried turning off Turbo-write (had it enabled via the CA Auto Turbo Write plugin), and writes to clearing disk (and parity) are up at 12-13 MB/s.  That's still pretty slow, but at least my system isn't getting crushed.

 

Any thoughts on why Turbo-write performance was so bad?  I thought it was supposed to help in situations like this.

Edited by veri745
B/b
Link to comment
  • Solution

The issue seems to be with Unraid still thinking the disk has a valid filesystem, if you stop the array and start it again so the disk shows unmountable, the write speed will increase dramatically. The only issue there is that the script won't work on an unmountable drive, so you must use the manual command line. If you mess up the command line, you can permanently erase a drive you didn't want to. If you are careful and match the md? correctly you will be ok.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...