Jump to content

VM not starting after attempting to change GPU passthrough


Recommended Posts

I am preparing to migrate to a new server and thought I could switch my VMs GPU to the other one that I have in my case but after making the switch, I remembered the reason I had this other GPU in there was because it's a server board with no graphics, so it's the system video. 

 

The reason I was trying to make the switch is I wanted to free up my 1060 NVIDIA card to run vdarr to convert my media library to h265. So I installed the NVIDIA plug in, moved the 710 GPU to the VM, and then realized that I couldn't pass that one through. 

 

So I uninstalled the NVIDIA plugin, remapped the VM to the 1060, but it won't come up. I've turned VM and Docker off and on, and rebooted server a few times. 

 

I am getting the following error in the libvrt log:

 

2023-05-25 02:30:48.049+0000: 13707: error : qemuDomainAgentAvailable:8610 : Guest agent is not responding: QEMU guest agent is not connected

 

Diagnostics attached.

 

Any thoughts appreciated.

 

 

hydra-diagnostics-20230524-2138.zip

Link to comment

Tried switching to the VNC and then back again for this VM. Here's the libvrt log entries. 

 

I'm kind of at a loss what to do to recover. 

 

2023-05-25 15:10:49.636+0000: 13707: error : qemuDomainAgentAvailable:8610 : Guest agent is not responding: QEMU guest agent is not connected
2023-05-25 15:11:05.861+0000: 13702: error : virNetSocketReadWire:1791 : End of file while reading data: Input/output error
2023-05-25 15:12:23.758+0000: 22579: error : qemuMonitorIORead:440 : Unable to read from monitor: Connection reset by peer
2023-05-25 15:12:23.759+0000: 22579: error : qemuProcessReportLogError:2056 : internal error: qemu unexpectedly closed the monitor: 2023-05-25T15:12:23.730373Z qemu-system-x86_64: -device pcie-pci-bridge,id=pci.8,bus=pci.1,addr=0x0: Bus 'pci.1' not found
2023-05-25 15:14:29.607+0000: 13803: error : virPCIGetHeaderType:2897 : internal error: Unknown PCI header type '127' for device '0000:04:00.0'
2023-05-25 15:14:45.234+0000: 13707: error : qemuDomainAgentAvailable:8610 : Guest agent is not responding: QEMU guest agent is not connected

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...