Jump to content

Attempting to cross flash HP H220 to LSI 9207-8i IT Mode

Recommended Posts

HBA - H220 with SAS2308_2(D1) controller


I've read a ton of things on the forums and I've been at this for hours and not making progress, so I'm hoping someone can help.  I downloaded the latest firmware,  My card is stuck and I can't do anything at this point.  In a UEFI shell, at least I can still see it, but can't apply firmware.  I know based on other posts, you need to flash to the latest with version 14 of sas2flash .  One issue is version 14 of the UEFI is not available on broadcoms site, it only goes to 15.  That being said, I found supposedly version 14 of it from another location on the web, "sas2hax," but I question if it's really version 14 as it shows version 19 when it runs.  


What I did to get where I'm at.


ran sas2flash -o -e 7

sas2flash -f mptsas2.rom

also have tried -f with the bin and rom at same time.


I keep getting (See screen shots)

No compatible NVDATA Image(s) found. 

Firmware Image Validation Failed!


I've also included what the it looked like before I erased the flash.


        Adapter Selected is a LSI SAS: SAS2308_2(D1)

        Controller Number              : 0
        Controller                     : SAS2308_2(D1)
        PCI Address                    : 00:05:00:00
        SAS Address                    : 500605b-0-0507-5fd0
        NVDATA Version (Default)       : 0d.44.00.01
        NVDATA Version (Persistent)    : 0d.44.00.01
        Firmware Product ID            : 0x2214
        Firmware Version               :
        NVDATA Vendor                  : LSI
        NVDATA Product ID              : SAS9207-8i
        BIOS Version                   :
        UEFI BSD Version               : N/A
        FCODE Version                  : N/A
        Board Name                     : H220
        Board Assembly                 : H3-25278-05D
        Board Tracer Number            : SV22626451

        Finished Processing Commands Successfully.
        Exiting SAS2Flash.


I have tried various versions and nothing is working.  Does anyone know how I might fix this as I've been at it for hours and not really getting anywhere.  Your help is appreciated!






Link to comment
7 minutes ago, deliverer said:

I got the card recovered with the HP firmware.  Every article mentions using SAS2FLASH version 14, but that version is not available on Broadcom's website.  Anyone have a copy of the UEFI version they can share with me?

I actually got it to work with the dos version vs the UEFI.  I think I'm good now.  FYI if anyone else runs into this, I did not find a UEFI version 14.  However, there is a dos version 14, but when you run via command line it shows version 10.  It was 100% downloaded in the version 14 package so who knows, but bottom line I finally got it flashed.  

Link to comment
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...