Jump to content

Cache Pool (Unmountable: No File System)

Go to solution Solved by JorgeB,

Recommended Posts

Hello everyone! I rarely post because I usually figure out issues myself as a long-time user of Unraid. However, I'm currently facing a problem. This morning, I woke up and noticed that my dockers had frozen overnight. When I accessed the Unraid WebUI, I saw that my main Cache pool was labeled as "Unmountable" (refer to the picture). This cache pool stores the following:


  • Appdata folder
  • System folder


I can't believe I disabled backups for it several months ago, so now it's crucial for me to see if I can recover as much as possible. I attempted to follow the steps for recovery, but I'm a bit confused at this stage.


v6.10-rc1 and newer use: Link to Source

mount -o rescue=all,ro /dev/sdX1 /temp

For a pool: replace X with any of the devices from the pool to mount the whole pool (as long as there are no devices missing), don't forget the 1 in the end


  • I replaced "X" with nvme0n1
  • My output was 
    mount -o rescue=all,ro /dev/sdnvme0n11 /temp


  • I then get the following output
mount: /temp: special device /dev/sdnvme0n11 does not exist.
       dmesg(1) may have more information after failed mount system call.


Any and all help would be greatly appreciated!


Screenshot 2023-06-10 at 09-36-52 VIPER_Main.png

Screenshot 2023-06-10 at 09-57-04 VIPER_Device.png

Screenshot 2023-06-10 at 10-01-42 VIPER_Syslog.png


Edited by viper81
Link to comment
  • Solution
18 hours ago, viper81 said:

My output was 

mount -o rescue=all,ro /dev/sdnvme0n11 /temp


Correct path would be /dev/nvme0n1p1, but first try typing in the CLI:

btrfs rescue zero-log /dev/nvme0n1p1

Then reboot to clear the logs and post new diags after array start.


Link to comment


5 hours ago, JorgeB said:

Correct path would be /dev/nvme0n1p1, but first try typing in the CLI:

btrfs rescue zero-log /dev/nvme0n1p1

Then reboot to clear the logs and post new diags after array start.


Thanks I did what you asked. You might see some dockers now in the logs. These are ones I just manually created to get my server up and running again. What's crazy is after I ran your command you gave me and rebooted the drives are back??

btrfs rescue zero-log /dev/nvme0n1p1


I started to backup and will make sure that my CA Appbackup is running again in the future. I just need to know if I need to set any CLI flags back or your recommendations?



Screenshot 2023-06-11 at 09-56-57 Tower - noVNC.png

Edited by viper81
add picture and more text
Link to comment

I want to add that I think I recovered everything and backed up my data. I really appreciate it. I also set back up CA backup again "properly".


btrfs rescue zero-log


Since it worked will it exit to zero-exit status after it recovered after the backtrace was completed? I really do appreciate all your help and I had a feeling you would be the one to reply!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...