Jump to content

BTRFS critical: unable to find logical [x] length [y]

Go to solution Solved by JorgeB,

Recommended Posts

Hello, first time writer here on the forum.


I installed Unraid last year in the midst of some unusual power outages. Despite my best efforts there were some interruptions to my Unraid server during the transfer of some files. I saw some errors during parity checks and within an NVME pool, but did not really visibly impact my experience.


Today, I recently had some docker updates done and now my Unraid server GUI is relatively less responsive or unresponsive. I am able to access the server itself and input commands - mainly powerdown - in an effort to see if a quick reboot would do the trick. So far no luck.


In the terminal are these messages repeated over and over:


BTRFS critical (device nvmeOn1p1): unable to find logical 9223372038827163648 length 4096
BTRFS critical (device nvmeOn1p1): unable to find logical 9223372038827163648 length 16384


Are there any terminal commands I can use to address this issue?


I can sign into the GUI, but mileage varies as far as how far I can even load certain pages.


Under the GUI, Fix Common Problems indicates that errors have been found with the sever, but I'm not able to load the plugin properly to see what it says. I've also tried to download the diagnostics through the GUI with no luck.



Edited by updatenil
Link to comment



Thanks. I normally interact with the GUI by accessing it on another computer on the network.


When I booted up the server into the GUI it works normally. I was able to get a new diagnostics file.


I realize I'm just not able to easily access the Unraid server on the network. I also notice that the server isn't able to reach GitHub.


Thanks for your kind attention to this.

Link to comment
  • Solution

Basically just copy anything important that you can elsewhere, like the array, you can use your favorite tool like midnight commander or the Dynamix file manager for example, then disable docker and VM services if still enabled, format the pool and copy the data back, and re-enable the services, and see if all works, docker may require a new image, but that's simple to do.

Link to comment

@JorgeB and @trurl


I thank you both for your kind attention to my issue. 


I am very much a layperson with a keen interest in setting up my humble homelab that's grown to this point. I would never have reached this point without these communities. Thank you again.


In summary, due to a long standing corruption in the cache from some power outages last year, the docker service finally stopped working. 


Solution: [1] stop docker and vm, [2] backup all important files from the impacted cache, [3] stop the array, [4] format the target cache, [5] return the files to the cache, and [5] restart docker.


My issues resolved at this point and I had no other steps to take.

Edited by updatenil
  • Like 1
  • Upvote 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...