Jump to content

6.12.0 - Existing ZFS Pool Import Issue

Go to solution Solved by StudiesTheBlade,

Recommended Posts

Hi all,


I am trying to import an existing ZFS pool into Unraid, but I am getting the "Unmountable: Unsupported or no file system" error message for all the disks after starting the array. From what I've read in the documentation, my pool seems to be a supported configuration. It is 2 raidz1 vdevs with 4 drives each (see attached image). I have tried creating the pool, assigning all drives, and then choosing zfs raidz 2x4 drives, but I still get the same result.


I was hoping someone could tell me I'm missing some step somewhere or if my array is somehow incompatible and why. I don't see any log entries in Unraid that seem to give any explaination of why it couldn't be mounted.


Thanks for your time!



Link to comment

I'm not seeing any pool import attempt but I missed this part before:



This device, and only this one, is using partition #2 for zfs, I assume it was previously replaced using TrueNAS?


I've never tried with just one device, but probably won't work, you can try if you want, it won't cause any harm to the pool, first export the pool:


zfs export tank

Then in the GUI create a new pool with 8 slots

assign all 8 devices to pool (don't assign sdj as the 1st device)

start array

post new diags


If this fails it should work if you replace that device with a different one (or the same disk) but using partition #1 for zfs.





Link to comment
Jun 15 12:20:48 stanley emhttpd: errors: No known data errors
Jun 15 12:20:48 stanley emhttpd: tank: device misplaced

I'm pretty sure this "device misplaced" error is because of that disk using partition #2.


3 minutes ago, StudiesTheBlade said:

A little sketchy, but should work, no?

It should, if you use the CLI it would rebuild using partition #1 and Unraid should then be able to import the pool.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...