Jump to content

Cache drive corrupt

Recommended Posts

Hi there, my cache drives seem corrupt, the mover and midnight commander won't copy the files to the main array.


This is after I foolishly broke things during a server upgrade. I moved to a new server with the same disks, and I wanted to rebuild the cache with different drives. So I turned off docker, vms, set all shares to Cache: Yes, and invoked the mover. Mover fails with lots of issues from one of the files (my VM disk :( ), and a scrub shows unrecoverable errors - how can they be unrecoverable if I have a pool of two cache disks?!


I get the following errors:


Jun 17 19:44:53 unraid kernel: BTRFS warning (device sdg1: state EA): csum failed root 5 ino 27798 off 5299212288 csum 0x8941f998 expected csum 0x5327b8b3 mirror 1
Jun 17 19:44:53 unraid kernel: BTRFS error (device sdg1: state EA): bdev /dev/sdg1 errs: wr 0, rd 0, flush 0, corrupt 11659, gen 0


Is there any way to save the files?



Link to comment
Jun 17 19:41:13 eTestes kernel: BTRFS info (device sdg1): bdev /dev/sdg1 errs: wr 0, rd 0, flush 0, corrupt 11658, gen 0
Jun 17 19:41:13 eTestes kernel: BTRFS info (device sdg1): bdev /dev/sdc1 errs: wr 0, rd 0, flush 0, corrupt 17055, gen 0


There is a lot of corruption detected on both devices, you should start by running memtest

Link to comment

Thank you so much for your replies JorgeB!


Update is: Even with XMP memory profile enabled, an all-night memtest shows fine. So I've got no idea what's caused this... None of the recovery options worked, even the destructive one just looped for ages printing the same error message about the same block.


I've lost my HomeAssistant VM image (but I have a config backup, so we'll see how well that restores...), but I think everything else is safe.


I'm kinda concerned about what the cause of this might have been, I thought having two drives in a pool would make me safe...

Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...