Jump to content

can't reconize by unraid my zfs pool

Recommended Posts

I can't reconfigure my zfs unraid 6.12 pool.

Before (6.11) with the zfs plugin all my pools were unraid and everything worked fine.

Now if I restart unraid
I have to do :
zfs import pool
zfs mount -a
restart Virtual VM & Docker (the libraries are on the ZFS Raid) via the interface (if you have the command line, I'd love to)

etc... it's not very good if a raid restarts by accident...

I tried creating a pool and adding 8 disks, plus one disk for cache) but nothing...

I tested with zfs export but nothing either...

I don't know if you have a step-by-step tutorial or an idea, but I'm interested.


all my disks are in unassigned with mount and zfs file...



Link to comment

Pool should be importable if you do this:


- First export the pool:

zpool export data

- Create a new Unraid pool with 10 slots

- Don't change the pool filesystem setting, leave in auto

- Assign all 10 pool members, 8 disk raidz + logs + cache vdevs

- Start array, if it doesn't import post new diags.


Also note that the pool has errors:


status: One or more devices has experienced an error resulting in data
    corruption.  Applications may be affected.
action: Restore the file in question if possible.  Otherwise restore the
    entire pool from backup.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...