Jump to content

Disk "not installed" and it stays that way.  Do I need to replace the disk?

Go to solution Solved by JorgeB,

Recommended Posts

This happened in the middle of a parity check today, at the same time I was downloading a lot.  Got hot disk reports (52C).  so i cleaned the PCs dust filters and vacuumed a little inside the case.  Then Disk 4 became "not installed" and it stays that way.

I tried stopping and starting the array, and different power and sata cables, and it stays this way. 


If I go to "Maintenance Mode" it also stays as "not installed".  Does that mean I cannot do a check and repair disk?

Do I need to replace the disk?  If I have to replace it, can I replace with a bigger drive?


Diagnostics attached.


I wanted to continue the parity check, but it only allows me to do a read check.  Parity check does not sho0w up as a choice.  So I am running a read check now.  











Edited by xrqp
Link to comment

Is it correct that if cable swapping is successful, the drive will no longer say "not installed"? 


It is an 8TB drive.  My parity is 18TB.

I did a "read" check.  It found some errors.   I swapped cables some more but it still says "not installed".  So can I replace the 8TB drive with 18TB drive then rebuild the 18TB drive?  Or do I have to pass "read check" and a "parity check" first?  I am unable to get Parity check to show as an option.  



Edited by xrqp
Link to comment

I took out the 8TB dsk4, and replaced it with 18TB, but now it shows in unassigned devices and does not show on the array.  Array still says disk4 is "not installed".  How do I get it into the array?


I am trying things to get the new drive to show in the array, as a choice in the disk4 dropdown:

  1. I stopped the array - it changed disk4 in the array to say "unassigned" instead of "not installed" so that feels like progress.  But when I click "unassigned" there is no other choice to change it.  So I still cannot get the replacement drive into the array.
  2. I stopped array and started in maintenance mode.  It did not help.
  3. The replacement drive had been precleared, but I used UD to "clear" it, to see if I could get it to show up in the disk4 array dropdown, but no success.  I formated it and tried again - no sucess.  tried with maint. mode and regular mode - no sucess.
Edited by xrqp
Link to comment

But to rebuild disk4 in the array, I cannot do it if it says "not installed", right?    If wrong, how do I rebuild it?

Do I rebuild it in UD? 


If I rebuild, can I rebuild the 18TB replacement, or must I rebuild the 8TB original?

Link to comment
6 minutes ago, xrqp said:

If I rebuild, can I rebuild the 18TB replacement, or must I rebuild the 8TB original?

Since you have 18TB parity drive you can rebuild to a replacement 18TB.   It will initially rebuild the contents of the (emulated) 8TB drive and then on completion expand the file system to fill the whole drive.

Link to comment

Last night i powered down the Unraid tower.  Today before turning on, I swapped the 18TB replacement back to the 8TB original disk4.  Powered up and it will not show up on my network - will not run headless.  I swapped back to the 18TB that had previously worked headless, but it remained off the network (not headless).  so for any suggestions on what to do, I will be doing it with a monitor and keyboard plugged in.


UPDATE.  I plugged in monitor and saw the IP address changed.  Using this new address, I am able now to run it from the network GUI.  I am back to showing the 18TB in UD, and array disk4 is "not installed".  How do I rebuild when "not installed" ?


My dashboard showed this:


Edited by xrqp
Link to comment

Here is info from my email warnings over the last week, in chronological order, oldest on top:


June 29, 6:09 PM 

Subject: Alert [TOWER] - Disk 4 in error state (disk dsbl)

Description: ST8000DM004-2CX188_WCT0VFC8 (sdf)


June 29, 6:09 PM

Subject: Warning [TOWER] - array has errors

Description: Array has 1 disk with read errors


June 29, 6:43 PM

Subject: Notice [TOWER] - Parity-Check finished (0 errors)

Description: Duration: 2 days, 18 hours, 1 minute, 18 seconds. Average speed: 75.7 MB/s


June 29, 7:55 PM

Subject: Notice [TOWER] - Read-Check started

Description: Size: 18.0 TB


June 29, 8:18 PM

Event: Unraid Disk 7 SMART health [199]

Subject: Warning [TOWER] - udma crc error count is 1


June 30, 9:33 AM

Event: Unraid Disk 7 SMART health [199]

Subject: Warning [TOWER] - udma crc error count is 2


June 30, 10:03 AM

Event: Unraid Disk 7 SMART health [199]

Subject: Warning [TOWER] - udma crc error count is 3


July 1, 2:44 AM

Event: Unraid Read-Check

Subject: Notice [TOWER] - Read-Check finished (932 errors)

Description: Canceled



Edited by xrqp
Link to comment

Thanks.  It is working and rebuilding.  My mistake was when the array was stopped and i clicked on disk 4 "unassigned" to see the drop down list, I did not see that the 2nd choice was there since it looked the same as the serial number of the drive below (disk 5).  I could only see the one choice which was unassigned.  But now I looked really close and could see I did have the 2nd choice.  So all is good now.  Thanks.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...